Bug 1572788 - Tag Control element does not work for single items in Service UI
Summary: Tag Control element does not work for single items in Service UI
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - Service
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: GA
: 5.9.2
Assignee: William Fitzgerald
QA Contact: Ruslana Babyuk
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-27 20:56 UTC by William Fitzgerald
Modified: 2018-05-09 13:10 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 13:10:09 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)
single value tag control cant add to cart (28.99 KB, image/png)
2018-04-27 21:03 UTC, William Fitzgerald
no flags Details

Description William Fitzgerald 2018-04-27 20:56:41 UTC
Description of problem:
In Service UI, when you use Tag Control element in your Dialog with a single value it doesn’t allow you to add to Shopping cart. 

I tried multiple tag control elements, same result.
This works in OPS UI.
This works with a Multi value tag control.


Version-Release number of selected component (if applicable):
Latest nightly build plus some UI-Component fixes

How reproducible:
100%

Steps to Reproduce:
1.  Create a dialog
2.  Select Tag control
3.  Select a catalog
4.  Set to multi values
5.  Crate a Catalog item using this dialog.
6.  Order from Service Catalog

Actual results:
Add to Shopping Cart is greyed out

Expected results:
Add to Shopping Cart is enabled and you can order your service.

Additional info:
See related BZ: https://bugzilla.redhat.com/show_bug.cgi?id=1570613

Comment 2 William Fitzgerald 2018-04-27 21:03:11 UTC
Created attachment 1427836 [details]
single value tag control cant add to cart

Comment 4 Tina Fitzgerald 2018-04-30 14:16:20 UTC
John,

I believe this issue is fixed already. Will report my findings here. 

Thanks,
Tina

Comment 5 William Fitzgerald 2018-04-30 15:12:05 UTC
Correction in Steps to Reproduce: 

4.  Set to SINGLE value

Comment 6 Tina Fitzgerald 2018-05-01 13:58:39 UTC
Waiting on new SUI build.

Comment 8 William Fitzgerald 2018-05-02 15:26:10 UTC
Works on latest build 5.9.2.4

Comment 9 William Fitzgerald 2018-05-02 20:09:57 UTC
This works with latest release 5.9.2.4


Note You need to log in before you can comment on or make changes to this bug.