Bug 15728 - tripwire causing segfault in mail
Summary: tripwire causing segfault in mail
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mailx   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
: 15955 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-08 14:54 UTC by Aaron Brown
Modified: 2005-10-31 22:00 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-11 18:35:30 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aaron Brown 2000-08-08 14:54:27 UTC
After I installed from the "qa2" tree built on Aug 7, I keep getting
emails telling me that the tripwire database is not found.  Upon
quitting mail, I get a segfault.

Comment 1 Glen Foster 2000-08-09 13:54:07 UTC
Not a tripwire problem - changing component to "mailx" per Aaron Brown.  The
binary that dumps core is /bin/mail.  Aaron will attach some of the strace
output to this defect ASAP.

Comment 2 Aaron Brown 2000-08-09 14:01:13 UTC
Here is the tail end of the strace I did while exiting
from "mail":


open("/var/spool/mail/root", O_RDONLY)  = 3
fcntl(3, F_GETFL)                       = 0 (flags O_RDONLY)
fstat(3, {st_mode=S_IFREG|0600, st_size=414, ...}) = 0
old_mmap(NULL, 4096, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_ANONYMOUS, -1, 0) =
0x4001d000
_llseek(3, 0, [0], SEEK_CUR)            = 0
fcntl(3, F_SETFD, FD_CLOEXEC)           = 0
flock(3, LOCK_EX)                       = 0
fstat(3, {st_mode=S_IFREG|0600, st_size=414, ...}) = 0
--- SIGSEGV (Segmentation fault) ---

Comment 3 Jeff Johnson 2000-08-11 18:35:27 UTC
*** Bug 15955 has been marked as a duplicate of this bug. ***

Comment 4 Jeff Johnson 2000-08-11 19:28:12 UTC
I believe this is fixed in mailx-8.1.1-17.


Note You need to log in before you can comment on or make changes to this bug.