Bug 157280 - nvidia.ko can't load on Intel SE7525GP2 Mother board
nvidia.ko can't load on Intel SE7525GP2 Mother board
Status: CLOSED DUPLICATE of bug 73733
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
4
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-10 01:25 EDT by Masahiro Takahashi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-10 01:37:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
nvidia bug report form. It contains all info. (88.75 KB, text/plain)
2005-05-10 01:25 EDT, Masahiro Takahashi
no flags Details

  None (edit)
Description Masahiro Takahashi 2005-05-10 01:25:52 EDT
Description of problem:

I tried to install NVIDIA-Linux-x86_64-1.0-7174-pkg2.run on kernel-2.6.11-
1.1287_FC4smp, Nvidia installer was failed.
It seemed that compiling "nvidia.ko" was successful, but loading module was 
failed.

Version-Release number of selected component (if applicable):
kernel-2.6.11-1.1287_FC4smp

How reproducible:
Every Time.

Steps to Reproduce:
1.install fc4 test2 with "Everything" and yum update
2.get http://download.nvidia.com/XFree86/Linux-x86_64/1.0-7174/NVIDIA-Linux-
x86_64-1.0-7174-pkg2.run
3.Execute NVIDIA-Linux-x86_64-1.0-7174-pkg2.run
  
Actual results:
Nvidia VGA driver install ended with error.
and nvidia.ko modules was not loaded.
Installer messages were following.
ERROR: Unable to load the kernel module 'nvidia.ko'.  This is most likely
       because the kernel module was built using the wrong kernel source
       files.  Please make sure you have installed the kernel source files
       for your kernel; on Red Hat Linux systems, for example, be sure you
       have the 'kernel-source' rpm installed.  If you know the correct
       kernel source files are installed, you may specify the kernel source
       path with the '--kernel-source-path' commandline option.

Following is dmesg
nvidia: module license 'NVIDIA' taints kernel.
ACPI: PCI Interrupt 0000:03:00.0[A] -> GSI 16 (level, low) -> IRQ 169
NVRM: This IO region assigned to your NVIDIA device is invalid:
NVRM: BAR1 is 0M @ 0x00000000 (PCI:0003:00.0)
NVRM: The system BIOS may have misconfigured your graphics card.
nvidia: probe of 0000:03:00.0 failed with error -1
NVRM: The NVIDIA probe routine failed for 1 device(s).
NVRM: None of the NVIDIA graphics adapters were initialized!

Expected results:
It should be load nvidia.ko successfully.

Additional info:
Environment:
MB:        Intel SE7525GP2
CPU:       Xeon 2.8G (EM64T) x2
Mem:       1GB x2
PCI-e x16: Nvidia GeForce 6200
PCI-e x4:  Blank
PCI:       AHA-2940U/UW (It has 2 SCSI channel on a board)
           iTVC15 MPEG-2 Encoder
           IEEE 1394: TI IEEE-1394b (64bit PCI)
           SiI 3124 PCI-X Serial ATA RAID (PCI-X)
SE7525GP2's BIOS setting has only "Dual Display(On board VGA and PCI-E)"
and "Disable on board VGA" only.

I also tried Fedora core 3 x86_64 with kernel-2.6.11-1.14_FC3,
it was failed too.
This hardware configuration was worked fine on Windows XP 32bit.

I reported to linux-bugs@nvidia.com, Nvidia said that
the kernel does not know hot to handle 64 bit PCI I/O regions.

Regards,
Masahiro
Comment 1 Masahiro Takahashi 2005-05-10 01:25:52 EDT
Created attachment 114190 [details]
nvidia bug report form. It contains all info.
Comment 2 Warren Togami 2005-05-10 01:37:01 EDT

*** This bug has been marked as a duplicate of 73733 ***

Note You need to log in before you can comment on or make changes to this bug.