Bug 1572825 - FFU: openstack overcloud upgrade run --roles $role --skip-tags validation fails and exits with 'headers' output [NEEDINFO]
Summary: FFU: openstack overcloud upgrade run --roles $role --skip-tags validation fai...
Keywords:
Status: CLOSED DUPLICATE of bug 1568714
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: rc
: ---
Assignee: mathieu bultel
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-28 00:50 UTC by Marius Cornea
Modified: 2018-05-09 15:41 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 15:41:16 UTC
Target Upstream Version:
mandreou: needinfo? (mbultel)


Attachments (Terms of Use)

Description Marius Cornea 2018-04-28 00:50:34 UTC
Description of problem:
FFU: upgrade CLI exits with return code 1 even though the ansible playbook completed successfully.

Version-Release number of selected component (if applicable):
python-tripleoclient-9.2.1-3.el7ost.noarch

How reproducible:
100%

Steps to Reproduce:
1. openstack overcloud upgrade run --nodes compute-0 --skip-tags validation; echo $?

Actual results:

 u'TASK [Install docker packages on upgrade if missing] ***************************',
 u'skipping: [192.168.24.13] => {"changed": false, "skip_reason": "Conditional result was False"}',
 u'',
 u'TASK [blank ipv6 rule before activating ipv6 firewall.] ************************',
 u'skipping: [192.168.24.13] => {"changed": false, "skip_reason": "Conditional result was False"}',
 u'']
'headers'
1

In ansible mistral log we can actually see that the playbook completed successfully:

[root@undercloud-0 v1]# tail -10 /tmp/ansible-mistral-action_DonWC/ansible.log
2018-04-27 20:42:57,728 p=27008 u=mistral |  TASK [Update all packages] *****************************************************
2018-04-27 20:42:57,750 p=27008 u=mistral |  skipping: [192.168.24.13] => {"changed": false, "skip_reason": "Conditional result was False"}
2018-04-27 20:42:57,763 p=27008 u=mistral |  TASK [include] *****************************************************************
2018-04-27 20:42:57,782 p=27008 u=mistral |  skipping: [192.168.24.13] => {"changed": false, "skip_reason": "Conditional result was False"}
2018-04-27 20:42:57,794 p=27008 u=mistral |  TASK [include] *****************************************************************
2018-04-27 20:42:57,818 p=27008 u=mistral |  skipping: [192.168.24.13] => {"changed": false, "skip_reason": "Conditional result was False"}
2018-04-27 20:42:57,831 p=27008 u=mistral |  TASK [include] *****************************************************************
2018-04-27 20:42:57,854 p=27008 u=mistral |  skipping: [192.168.24.13] => {"changed": false, "skip_reason": "Conditional result was False"}
2018-04-27 20:42:57,856 p=27008 u=mistral |  PLAY RECAP *********************************************************************
2018-04-27 20:42:57,856 p=27008 u=mistral |  192.168.24.13              : ok=73   changed=55   unreachable=0    failed=0   


Expected results:
The cli returns the correct code.

Additional info:
This is a major issue as it blocks automation.

Comment 1 Marius Cornea 2018-04-29 22:13:06 UTC
Actually it appears that his is a legitimate failure and only the upgrade_steps_playbook.yaml got run without 'deploy_steps_playbook.yaml', 'post_upgrade_steps_playbook.yaml'. The output is misleading and doesn't point to what was/caused the error.

Comment 2 Jose Luis Franco 2018-04-30 14:24:46 UTC
@Mathieu, this BZ has been assigned to you during triage duty call. Please, feel free to reasign.

Comment 5 Lukas Bezdicka 2018-05-09 15:41:16 UTC

*** This bug has been marked as a duplicate of bug 1568714 ***


Note You need to log in before you can comment on or make changes to this bug.