Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1572834 - RFE: osc-placement plugin should be packaged in OSP12 (and later)
Summary: RFE: osc-placement plugin should be packaged in OSP12 (and later)
Keywords:
Status: CLOSED DUPLICATE of bug 1610308
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 12.0 (Pike)
Assignee: Matthew Booth
QA Contact: nova-maint
URL:
Whiteboard:
Depends On: 1607877
Blocks: bu-gpu-crash
TreeView+ depends on / blocked
 
Reported: 2018-04-28 02:27 UTC by Lars Kellogg-Stedman
Modified: 2019-09-09 14:03 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-09 15:49:56 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lars Kellogg-Stedman 2018-04-28 02:27:23 UTC
In diagnosing some issues at Boston University, we discovered some stale allocations in the placement service.  In order to diagnose and repair these issues, we needed the osc-placement plugin [1] for the openstack cli.

This tool is not included in OSP12, which makes it difficult for operators to correct or diagnose these issues.

The tool should be packaged with any RHOSP release that includes the placement service (at least 12, if not earlier).

[1]: https://docs.openstack.org/osc-placement/latest/index.html

Comment 1 melanie witt 2018-05-04 14:41:13 UTC
We discussed this in our bug triage call today and agreed we should package and ship the osc-placement plugin with RHOSP that includes the placement service. Since the placement service started handling allocations in OSP11 (ocata), we think osc-placement should be packaged and shipped with OSP11 and onward.

Comment 4 Matthew Booth 2018-07-24 13:54:47 UTC
RDO package review submitted: https://bugzilla.redhat.com/show_bug.cgi?id=1607877

Comment 5 Matthew Booth 2018-08-09 15:49:56 UTC
We're going to add the package to OSP13 onwards. We've decided not to add it to 12, though, because there was no upstream Pike release of osc-placement. If there's a need to use osc-placement against OSP12, though, you should be able to install the client from OSP13 (when it's available).

*** This bug has been marked as a duplicate of bug 1610308 ***


Note You need to log in before you can comment on or make changes to this bug.