Bug 1572859 - installer unable to overwrite node name to registry itself to master by setting openshift_hostname
Summary: installer unable to overwrite node name to registry itself to master by setti...
Keywords:
Status: CLOSED DUPLICATE of bug 1613765
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Documentation
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Alex Dellapenta
QA Contact: Johnny Liu
Vikram Goyal
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-28 08:11 UTC by Johnny Liu
Modified: 2018-08-09 05:41 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-08-09 05:41:18 UTC
Target Upstream Version:


Attachments (Terms of Use)
installation log with inventory file embedded (1.46 MB, text/plain)
2018-04-28 08:11 UTC, Johnny Liu
no flags Details

Description Johnny Liu 2018-04-28 08:11:56 UTC
Created attachment 1427985 [details]
installation log with inventory file embedded

Description of problem:
see the following details

Version-Release number of the following components:
openshift-ansible-3.10.0-0.30.0.git.0.4f02952.el7.noarch

How reproducible:
Always

Steps to Reproduce:
1. launch an instance, its hostname is "test"
2. prepare inventory file, setting openshift_hostname="aa.bb.com" to overwrite its hostname for this node, which is resolved to this instance's IP.
3. trigger installation

Actual results:
After installation, run `oc get node`, the node is registered as "test", but not "aa.bb.com".

# grep -i nodename /etc/origin/node/node-config.yaml

Expected results:
node should be registered as "aa.bb.com"


Additional info:
I track down a bit for this issue, node start script is located at /usr/local/bin/openshift-node, in which there are the following line:
flags=$( /usr/bin/openshift start node --write-flags "--config=${config}" --loglevel=${DEBUG_LOGLEVEL:-2} )

seem like the command never prints out "nodeName" flag, even if I manually added "nodeName" into node-config file.

Comment 1 Scott Dodson 2018-05-02 14:32:24 UTC
nodeName is no longer configurable, what problems arrise from the new behavior?

Comment 2 Johnny Liu 2018-05-08 02:47:49 UTC
If nodeName is no longer configurable, node host will use its hostname to registry itself, if node's hostname is not resolvable, that would lead to the node can not succeed to registry itself.

Such as:
master + node1: hostname is "test"
node2: hostname is "test1"

"test" and "test1" is not resolvable between hosts, only resolvable on node itself.

Then after installation, run `oc get node`, only "test" is listed there, "test1" is missing.


BTW, if nodeName is no longer configurable, doc also have to be updated accordingly.

Comment 3 Seth Jennings 2018-05-08 20:11:40 UTC
see https://bugzilla.redhat.com/show_bug.cgi?id=1566455#c10

Comment 4 Scott Dodson 2018-05-09 12:43:07 UTC

*** This bug has been marked as a duplicate of bug 1566455 ***

Comment 5 Johnny Liu 2018-05-09 16:00:36 UTC
I do not think this is not a dup of bug 1566455, this bug is tracking for openshift_hostname overwrite issue which is irrelevant to any cloud provider, bug 1566455 is tracking for openshift cloudprovider issue.

Just like the scenario what I mentioned in comment 2, if we insist nodeName is no longer configurable, to make the installation mentioned in comment 2 move on, user have to change system hostname to some resolvable fdqn. This bug should be move to a doc bug to explain such scenario and remove all the occurrence where mention "nodeName" and ""openshift_hostname".

Comment 8 Alex Dellapenta 2018-06-01 21:27:05 UTC
Docs PR:

https://github.com/openshift/openshift-docs/pull/9744

Comment 9 Johnny Liu 2018-06-04 10:15:35 UTC
Seem like no update for nodeName in the doc, now nodeName is not configurable and not shown in node config yaml file.

Comment 10 Alex Dellapenta 2018-07-30 04:47:42 UTC
Updated to remove nodeName from node-config.yaml as well:

https://github.com/openshift/openshift-docs/pull/9744

Comment 11 Johnny Liu 2018-07-30 09:18:37 UTC
Search cross the whole doc, seem like still have some place using reference to "openshift_hostname", such as: https://github.com/openshift/openshift-docs/search?q=openshift_hostname&unscoped_q=openshift_hostname

Comment 13 Vikram Goyal 2018-08-09 05:41:18 UTC
@Alex - I am closing this in favor of the new one that was reported - and is being worked on by Kathryn.

*** This bug has been marked as a duplicate of bug 1613765 ***


Note You need to log in before you can comment on or make changes to this bug.