Bug 1572867 - [abrt] audacity: XGetWindowProperty(): audacity killed by SIGTRAP
Summary: [abrt] audacity: XGetWindowProperty(): audacity killed by SIGTRAP
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: audacity
Version: 27
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: David Timms
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:49585da94cae8037cf49fd919bc...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-28 09:32 UTC by Stepan Broz
Modified: 2018-11-02 19:21 UTC (History)
4 users (show)

Fixed In Version: audacity-2.3.0-1.fc29 audacity-2.3.0-1.fc27 audacity-2.3.0-1.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-10-30 17:18:32 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (58.95 KB, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details
File: cgroup (197 bytes, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details
File: core_backtrace (19.87 KB, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details
File: cpuinfo (1.40 KB, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details
File: dso_list (12.55 KB, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details
File: environ (1.81 KB, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details
File: limits (1.29 KB, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details
File: maps (60.01 KB, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details
File: mountinfo (4.62 KB, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details
File: open_fds (1.14 KB, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details
File: proc_pid_status (1.29 KB, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details
File: var_log_messages (11.68 KB, text/plain)
2018-04-28 09:32 UTC, Stepan Broz
no flags Details

Description Stepan Broz 2018-04-28 09:32:07 UTC
Description of problem:
Just started recording a mono track, ALSA, USB exteral souncard, Jabra EVOLVE LINK MS, can't select a stereo source (it's just a mic). Reproducible always.

Version-Release number of selected component:
audacity-2.1.3-5.fc27

Additional info:
reporter:       libreport-2.9.3
backtrace_rating: 4
cmdline:        audacity
crash_function: XGetWindowProperty
executable:     /usr/bin/audacity
journald_cursor: s=7a921adeaa7d4111b2496fded44dc933;i=15a68;b=9cc5588cc3f448a5965199b33a9c1430;m=19b7b811938;t=56ae511ede51f;x=3f14ed48796dcc0d
kernel:         4.15.14-300.fc27.x86_64
rootdir:        /
runlevel:       N 5
type:           CCpp
uid:            102047

Comment 1 Stepan Broz 2018-04-28 09:32:14 UTC
Created attachment 1428004 [details]
File: backtrace

Comment 2 Stepan Broz 2018-04-28 09:32:16 UTC
Created attachment 1428005 [details]
File: cgroup

Comment 3 Stepan Broz 2018-04-28 09:32:18 UTC
Created attachment 1428006 [details]
File: core_backtrace

Comment 4 Stepan Broz 2018-04-28 09:32:19 UTC
Created attachment 1428007 [details]
File: cpuinfo

Comment 5 Stepan Broz 2018-04-28 09:32:21 UTC
Created attachment 1428008 [details]
File: dso_list

Comment 6 Stepan Broz 2018-04-28 09:32:22 UTC
Created attachment 1428009 [details]
File: environ

Comment 7 Stepan Broz 2018-04-28 09:32:23 UTC
Created attachment 1428010 [details]
File: limits

Comment 8 Stepan Broz 2018-04-28 09:32:25 UTC
Created attachment 1428011 [details]
File: maps

Comment 9 Stepan Broz 2018-04-28 09:32:27 UTC
Created attachment 1428012 [details]
File: mountinfo

Comment 10 Stepan Broz 2018-04-28 09:32:28 UTC
Created attachment 1428013 [details]
File: open_fds

Comment 11 Stepan Broz 2018-04-28 09:32:29 UTC
Created attachment 1428014 [details]
File: proc_pid_status

Comment 12 Stepan Broz 2018-04-28 09:32:31 UTC
Created attachment 1428015 [details]
File: var_log_messages

Comment 13 David Timms 2018-10-03 12:46:42 UTC
When you say "can't select a stereo source", is that because it isn't in the list ?

Can you please test against 2.3.0 in updates-testing and report back ?

Comment 14 Fedora Update System 2018-10-03 13:02:23 UTC
audacity-2.3.0-1.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-5c01437fa7

Comment 15 Fedora Update System 2018-10-03 13:03:05 UTC
audacity-2.3.0-1.fc29 has been submitted as an update to Fedora 29. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9e098024ad

Comment 16 Fedora Update System 2018-10-03 13:03:48 UTC
audacity-2.3.0-1.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-e66ef16e01

Comment 17 Fedora Update System 2018-10-03 15:42:21 UTC
audacity-2.3.0-1.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-5c01437fa7

Comment 18 Fedora Update System 2018-10-04 18:00:46 UTC
audacity-2.3.0-1.fc29 has been pushed to the Fedora 29 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9e098024ad

Comment 19 Fedora Update System 2018-10-04 21:10:24 UTC
audacity-2.3.0-1.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-e66ef16e01

Comment 20 Fedora Update System 2018-10-30 17:18:32 UTC
audacity-2.3.0-1.fc29 has been pushed to the Fedora 29 stable repository. If problems still persist, please make note of it in this bug report.

Comment 21 Fedora Update System 2018-11-01 17:09:33 UTC
audacity-2.3.0-1.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.

Comment 22 Fedora Update System 2018-11-02 19:21:23 UTC
audacity-2.3.0-1.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.