Bug 1572868 - Need update atomic-openshift-node.service in node system container
Summary: Need update atomic-openshift-node.service in node system container
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.10.0
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-28 09:44 UTC by DeShuai Ma
Modified: 2018-07-30 19:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:04 UTC

Description DeShuai Ma 2018-04-28 09:44:50 UTC
Description of problem:
When press 'Tab' it can tip atomic-openshift-master-controllers.service ? but actually there is no the service; After check the atomic-openshift-node.service, find there are lots of different with rpm env.
[root@ip-172-18-15-219 atomic-openshift-node]# systemctl status atomic-openshift-node
atomic-openshift-node-dep.service  atomic-openshift-node.service      
[root@ip-172-18-15-219 atomic-openshift-node]# systemctl status atomic-openshift-node-dep.service 
Unit atomic-openshift-node-dep.service could not be found.

Version-Release number of the following components:
openshift-ansible-3.10.0-0.30.0.git.0.4f02952.el7.noarch.rpm
openshift v3.10.0-0.30.0
node system container:
registry.reg-aws.openshift.com:443/openshift3/ose-node                      v3.10    722eec174b12   2018-04-28 03:57   411.15 MB      ostree    


How reproducible:
Always

Steps to Reproduce:
1. Check atomic-openshift-node.service in node system container
[root@ip-172-18-15-219 atomic-openshift-node]# pwd
/var/lib/containers/atomic/atomic-openshift-node
[root@ip-172-18-15-219 atomic-openshift-node]# ls
atomic-openshift-node.service  config.json  info  rootfs  tmpfiles-atomic-openshift-node.conf
[root@ip-172-18-15-219 atomic-openshift-node]# cat atomic-openshift-node.service 
[Unit]
After=docker.service
Wants=docker.service
After=atomic-openshift-node-dep.service
After=atomic-openshift-master-controllers.service
Requires=dnsmasq.service
After=dnsmasq.service

[Service]
Type=notify
EnvironmentFile=/etc/sysconfig/atomic-openshift-node

ExecStartPre=/bin/bash -c 'export -p > /run/atomic-openshift-node-env'
ExecStart=/usr/bin/runc --systemd-cgroup run 'atomic-openshift-node'
ExecStop=/usr/bin/runc --systemd-cgroup kill 'atomic-openshift-node'
SyslogIdentifier=atomic-openshift-node
Restart=always
RestartSec=5s
WorkingDirectory=/var/lib/containers/atomic/atomic-openshift-node.0
RuntimeDirectory=atomic-openshift-node

[Install]
WantedBy=docker.service


Actual results:
1) Need remove "After=atomic-openshift-node-dep.service
After=atomic-openshift-master-controllers.service"
2) need sync the file with rpm


Expected results:
//The correct rpm env:
[root@host-172-16-120-149 ~]# systemctl cat atomic-openshift-node.service
# /etc/systemd/system/atomic-openshift-node.service
[Unit]
Description=OpenShift Node
After=docker.service
After=chronyd.service
After=ntpd.service
Wants=docker.service
Documentation=https://github.com/openshift/origin
Wants=dnsmasq.service
After=dnsmasq.service
Wants=cri-o.service
[Service]
Type=notify
EnvironmentFile=/etc/sysconfig/atomic-openshift-node
ExecStart=/usr/local/bin/openshift-node
LimitNOFILE=65536
LimitCORE=infinity
WorkingDirectory=/var/lib/origin/
SyslogIdentifier=atomic-openshift-node
Restart=always
RestartSec=5s
TimeoutStartSec=300
OOMScoreAdjust=-999

[Install]
WantedBy=multi-user.target

# /etc/systemd/system/atomic-openshift-node.service.d/override.conf
[Unit]
After=cloud-init.service


Additional info:
Please attach logs from ansible-playbook with the -vvv flag

Comment 1 Scott Dodson 2018-05-11 18:48:13 UTC
https://github.com/openshift/origin/pull/19694

Comment 2 Scott Dodson 2018-05-18 15:21:30 UTC
In v3.10.0-0.42.0 and later

Comment 3 Johnny Liu 2018-05-22 10:24:22 UTC
Verified this bug with 3.10.0-0.50.0 build, and PASS.

# oc version
oc v3.10.0-0.50.0
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

Server https://qe-jialiu310-master-etcd-1:8443
openshift v3.10.0-0.50.0
kubernetes v1.10.0+b81c8f8

# cat /etc/redhat-release 
Red Hat Enterprise Linux Atomic Host release 7.5

# systemctl cat atomic-openshift-node.service
# /etc/systemd/system/atomic-openshift-node.service
[Unit]
After=docker.service
Wants=docker.service
Requires=dnsmasq.service
After=dnsmasq.service

[Service]
Type=notify
EnvironmentFile=/etc/sysconfig/atomic-openshift-node

ExecStartPre=/bin/bash -c 'export -p > /run/atomic-openshift-node-env'
ExecStart=/usr/bin/runc --systemd-cgroup run 'atomic-openshift-node'
ExecStop=/usr/bin/runc --systemd-cgroup kill 'atomic-openshift-node'
SyslogIdentifier=atomic-openshift-node
Restart=always
RestartSec=5s
WorkingDirectory=/var/lib/containers/atomic/atomic-openshift-node.0
RuntimeDirectory=atomic-openshift-node

[Install]
WantedBy=docker.service

Comment 5 errata-xmlrpc 2018-07-30 19:14:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.