Bug 1572869 - [CRI-O] Need use openshift3/ose-pod as default infra image in crio product version
Summary: [CRI-O] Need use openshift3/ose-pod as default infra image in crio product ve...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Containers
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
: 3.10.0
Assignee: Urvashi Mohnani
QA Contact: DeShuai Ma
URL:
Whiteboard:
Depends On:
Blocks: 1573693
TreeView+ depends on / blocked
 
Reported: 2018-04-28 09:51 UTC by DeShuai Ma
Modified: 2018-07-30 19:15 UTC (History)
13 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1573693 (view as bug list)
Environment:
Last Closed: 2018-07-30 19:14:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:04 UTC

Description DeShuai Ma 2018-04-28 09:51:19 UTC
Description of problem:
In openshift product we should avoid use k8s pause image as default infra image in /etc/crio/crio.conf

Version-Release number of selected component (if applicable):
cri-o-1.10.0-1.beta.1.gitc956614.el7.x86_64
openshift v3.10.0-0.30.0

How reproducible:
Always

Steps to Reproduce:
1.Check the pause image
[root@host-172-16-120-149 ~]# grep "pause" /etc/crio/crio.conf
# pause_image is the image which we use to instantiate infra containers.
pause_image = "kubernetes/pause"
# pause_command is the command to run in a pause_image to have a container just
pause_command = "/pause"

2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 DeShuai Ma 2018-05-02 08:47:37 UTC
Now we use the following walkaround to fix our env after complete installation:

1. update "pause_image" and "pause_command" in "/etc/crio/crio.conf"
pause_image = "registry.reg-aws.openshift.com:443/openshift3/ose-pod:v3.10"
pause_command = "/usr/bin/pod"

2. Then in all node run
yum install crictl
crictl pull registry.reg-aws.openshift.com:443/openshift3/ose-pod:v3.10
systemctl restart crio
kill -9 `pidof pause`
systemctl restart atomic-openshift-node.service

Comment 2 DeShuai Ma 2018-05-02 08:55:52 UTC
As customer already met can't pull the kubernetes/pause issue in disconnected installation and we always need walkaround when do 3.10 crio test. 
Move the bug to H/H.

Comment 3 DeShuai Ma 2018-05-02 08:59:04 UTC
In comment 1 step1, we also need restart crio service after update the crio.conf

Comment 5 Scott Dodson 2018-05-03 16:57:47 UTC
It looks like Mrunal is taking ownership of this.

Comment 6 Urvashi Mohnani 2018-05-04 18:08:40 UTC
Being fixed in https://github.com/openshift/openshift-ansible/pull/8262

Comment 8 Urvashi Mohnani 2018-05-10 16:54:15 UTC
Issue being fixed for 3.10 in https://github.com/openshift/openshift-ansible/pull/8287.
There are some issues with the CRI-O CI, so waiting on that.

Comment 9 Urvashi Mohnani 2018-05-10 19:50:26 UTC
Fix has been merged upstream. DeShuai please try it out.

Comment 10 DeShuai Ma 2018-05-11 05:25:33 UTC
Comment add to the 3.9 bug
https://bugzilla.redhat.com/show_bug.cgi?id=1573693#c8

Comment 11 DeShuai Ma 2018-05-11 05:31:14 UTC
Could you take a look at the comment 7 Is a new bug?

Comment 12 Urvashi Mohnani 2018-05-11 13:53:03 UTC
Fixed by https://github.com/openshift/openshift-ansible/pull/8337. Please retest.

Comment 13 Scott Dodson 2018-05-14 12:37:10 UTC
Fixed in openshift-ansible-3.10.0-0.40.0 and later.

Comment 14 DeShuai Ma 2018-05-15 03:23:54 UTC
Verify on openshift-ansible-3.10.0-0.41.0.git.0.88119e4.el7.noarch.rpm

[root@qe-dma-master-etcd-1 ~]# grep 'pause' /etc/crio/crio.conf
# pause_image is the image which we use to instantiate infra containers.
pause_image = "registry.reg-aws.openshift.com:443/openshift3/ose-pod:v3.10"
# pause_command is the command to run in a pause_image to have a container just
pause_command = "/usr/bin/pod"
[root@qe-dma-master-etcd-1 ~]# systemctl status crio
● crio.service - Open Container Initiative Daemon
   Loaded: loaded (/usr/lib/systemd/system/crio.service; enabled; vendor preset: disabled)
   Active: active (running) since Mon 2018-05-14 22:42:46 EDT; 35min ago
     Docs: https://github.com/kubernetes-incubator/cri-o
 Main PID: 7346 (crio)
   CGroup: /system.slice/crio.service
           └─7346 /usr/bin/crio

May 14 23:17:45 qe-dma-master-etcd-1 conmon[10372]: conmon <ninfo>: about to waitpid: 10373
May 14 23:17:45 qe-dma-master-etcd-1 conmon[10372]: conmon <ninfo>: container PID: 10382
May 14 23:17:45 qe-dma-master-etcd-1 conmon[10372]: conmon <ninfo>: container 10382 exited with status 0
May 14 23:17:45 qe-dma-master-etcd-1 crio[7346]: time="2018-05-14 23:17:45.761385155-04:00" level=info msg="Received container exit code: 0, message: "
May 14 23:17:55 qe-dma-master-etcd-1 conmon[10493]: conmon <ninfo>: about to waitpid: 10494
May 14 23:17:55 qe-dma-master-etcd-1 conmon[10493]: conmon <ninfo>: container PID: 10503
May 14 23:17:55 qe-dma-master-etcd-1 crio[7346]: time="2018-05-14 23:17:55.765903941-04:00" level=info msg="Received container exit code: 0, message: "
May 14 23:18:05 qe-dma-master-etcd-1 conmon[10537]: conmon <ninfo>: about to waitpid: 10538
May 14 23:18:05 qe-dma-master-etcd-1 conmon[10537]: conmon <ninfo>: container PID: 10547
May 14 23:18:05 qe-dma-master-etcd-1 crio[7346]: time="2018-05-14 23:18:05.768168178-04:00" level=info msg="Received container exit code: 0, message: "

Comment 16 errata-xmlrpc 2018-07-30 19:14:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.