Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1572871 - Can't import esxi6.5 OVA file on rhv4.2
Summary: Can't import esxi6.5 OVA file on rhv4.2
Keywords:
Status: CLOSED DUPLICATE of bug 1553112
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Virt
Version: 4.2.0
Hardware: x86_64
OS: Unspecified
high
high
Target Milestone: ovirt-4.2.4
: ---
Assignee: Arik
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-28 10:13 UTC by mxie@redhat.com
Modified: 2019-04-28 10:08 UTC (History)
15 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-03 13:29:39 UTC
oVirt Team: Virt
rule-engine: ovirt-4.2+


Attachments (Terms of Use)
rhv4.2-esxi6.5-ova (82.01 KB, image/png)
2018-04-28 10:13 UTC, mxie@redhat.com
no flags Details
engine-esxi6.5-ova.log (23.06 KB, text/plain)
2018-04-28 10:13 UTC, mxie@redhat.com
no flags Details
vdsm-esxi6.5-ova.log (49.38 KB, text/plain)
2018-04-28 10:14 UTC, mxie@redhat.com
no flags Details
esxi6.5-rhel6.9-x86_64.ovf (6.42 KB, application/xml)
2018-05-02 03:47 UTC, mxie@redhat.com
no flags Details

Description mxie@redhat.com 2018-04-28 10:13:17 UTC
Created attachment 1428018 [details]
rhv4.2-esxi6.5-ova

Description of problem:
Can't import esxi6.5 OVA file on rhv4.2

Version-Release number of selected component (if applicable):
ovirt-engine-4.2.3.2-0.1.el7.noarch
vdsm-4.20.26-1.el7ev.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Import guest from ova file at rhv4.2 GUI
Login rhv4.2 -> click dashboard-> click virtual machine -> select import -> choose "vmware application (OVA)" and input path info

2.Failed to import guest from ova as screenshot "rhv4.2-esxi6.5-ova"


Actual results:
As above description

Expected results:
Can import esxi6.5 OVA file on rhv4.2

Additional info:
Can import esxi6.0 OVA file on rhv4.2

Comment 1 mxie@redhat.com 2018-04-28 10:13:49 UTC
Created attachment 1428019 [details]
engine-esxi6.5-ova.log

Comment 2 mxie@redhat.com 2018-04-28 10:14:20 UTC
Created attachment 1428020 [details]
vdsm-esxi6.5-ova.log

Comment 3 Michal Skrivanek 2018-04-29 04:46:04 UTC
Can you please attach the OVF too?

Comment 4 mxie@redhat.com 2018-05-02 03:47:08 UTC
Created attachment 1429640 [details]
esxi6.5-rhel6.9-x86_64.ovf

Comment 6 Pino Toscano 2018-05-03 12:00:18 UTC
At least looking at the logs, it seems like it is a parsing issue in the rhv engine;
with virt-v2v 1.38.1 the result is:

$ virt-v2v -i ova esx6_5-rhel6.9-x86_64.ova --print-source
[   0.0] Opening the source -i ova esx6_5-rhel6.9-x86_64.ova
Source guest information (--print-source option):

    source name: esx6_5-rhel6.9-x86_64
hypervisor type: vmware
         memory: 2147483648 (bytes)
       nr vCPUs: 1
     CPU vendor: 
      CPU model: 
   CPU topology: sockets: 1 cores/socket: 1 threads/core: 1
   CPU features: 
       firmware: bios
        display: 
          video: 
          sound: 
disks:
        json:{ "file": { "driver": "raw", "offset": 512, "size": 1634378752, "file": { "driver": "file", "filename": "esx6_5-rhel6.9-x86_64.ova" } } } (vmdk) [scsi]
removable media:
        CD-ROM [sata] in slot 0
        Floppy in slot 0
NICs:
        Bridge "VM Network" [vmxnet3]

Comment 7 Michal Skrivanek 2018-05-03 13:09:30 UTC
vdsm parses it as
FINISH getExternalVmFromOva return={'status': {'message': 'Done', 'code': 0}, 'vmList': {'status': 'Down', 'disks': [{'allocation': None, 'capacity': '17179869184', 'type': 'disk', 'alias': 'esx6_5-rhel6.9-x86_64-1.vmdk'}], 'smp': 1, 'memSize': 2048, 'vmName': 'esx6_5-rhel6.9-x86_64', 'networks': [{'bridge': 'VM Network', 'model': 'VmxNet3', 'type': 'bridge', 'dev': 'Network adapter 1'}]}}

Comment 8 Michal Skrivanek 2018-05-03 13:11:59 UTC
then fails with 
2018-05-03 16:08:36,123+03 ERROR [org.ovirt.engine.core.bll.GetVmFromOvaQuery] (default task-87) [e9736d2e-148a-4847-b572-fd97e54ebcd4] Exception: org.ovirt.engine.
core.common.errors.EngineException: EngineException: java.lang.NumberFormatException: null (Failed with error ENGINE and code 5001)
        at org.ovirt.engine.core.bll.VdsHandler.handleVdsResult(VdsHandler.java:118) [bll.jar:]
...

which is the same issue as https://bugzilla.redhat.com/show_bug.cgi?id=1553112#c6

Comment 9 Michal Skrivanek 2018-05-03 13:29:39 UTC

*** This bug has been marked as a duplicate of bug 1553112 ***


Note You need to log in before you can comment on or make changes to this bug.