Bug 1573066 - growing glusterd memory usage with connected RHGSWA
Summary: growing glusterd memory usage with connected RHGSWA
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sanju
QA Contact:
URL:
Whiteboard:
Depends On: 1566023 1567899
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 05:44 UTC by Sanju
Modified: 2018-06-20 18:05 UTC (History)
12 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1567899
Environment:
Last Closed: 2018-06-20 18:05:40 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Worker Ant 2018-04-30 05:46:50 UTC
REVIEW: https://review.gluster.org/19948 (glusterd: Fix for memory leak in get-state detail) posted (#1) for review on master by Sanju Rakonde

Comment 2 Worker Ant 2018-05-01 03:42:29 UTC
COMMIT: https://review.gluster.org/19948 committed in master by "Atin Mukherjee" <amukherj@redhat.com> with a commit message- glusterd: Fix for memory leak in get-state detail

Fixes: bz#1573066
Change-Id: I76fe3bdde7351736b32eb3d6c4cc5f8f276257ed
Signed-off-by: Sanju Rakonde <srakonde@redhat.com>

Comment 3 Shyamsundar 2018-06-20 18:05:40 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.