Bug 157307 - gnome-terminal opening a new pty oopses the kernel
gnome-terminal opening a new pty oopses the kernel
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
Depends On:
  Show dependency treegraph
Reported: 2005-05-10 10:18 EDT by Bill Nottingham
Modified: 2015-01-04 17:19 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2005-09-28 13:00:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Bill Nottingham 2005-05-10 10:18:41 EDT
Description of problem:

After running fine for ~10 days, opening a new pty in gnome-terminal oopses the

Unable to handle kernel NULL pointer dereference at virtual address 00000000
 printing eip:
*pde = 551bb067
Oops: 0000 [#1]
Modules linked in: rfcomm l2cap bluetooth loop tun radeon drm nfs lockd
parport_pc lp parport arc4 ieee80211_crypt_wep md5 ipv6 autofs4 pcmcia sunrpc
ipt_REJECT ipt_state ip_conntrack iptable_filter ip_tables dm_mod video ibm_acpi
button battery ac yenta_socket rsrc_nonstatic pcmcia_core uhci_hcd ehci_hcd
hw_random tpm_nsc tpm i2c_i801 i2c_core snd_intel8x0m snd_intel8x0
snd_ac97_codec snd_pcm_oss snd_mixer_oss snd_pcm snd_timer snd soundcore
snd_page_alloc ipw2200 ieee80211 ieee80211_crypt e1000 joydev ext3 jbd
CPU:    0
EIP:    0060:[<00000000>]    Not tainted VLI
EFLAGS: 00210286   (2.6.11-1.1261_FC4)
EIP is at 0x0
eax: c5615000   ebx: 01200011   ecx: 00000000   edx: 00000000
esi: f4691000   edi: f5d32bc4   ebp: c5615000   esp: c5615fc4
ds: 007b   es: 007b   ss: 0068
Process gnome-terminal (pid: 3870, threadinfo=c5615000 task=f4691000)
Stack: 01202011 00000000 00000000 00000000 b7fa8708 bffc6dfc 00000000 0020007b
       c010007b 00000078 00bbb7e2 00000073 00200282 bffc6d8c 0000007b
Call Trace:
Code:  Bad EIP value.

Will try a newer kernel later... this just spontaneously started. :/
Comment 1 Dave Jones 2005-09-28 04:54:17 EDT
did this ever show up again ?
Comment 2 Bill Nottingham 2005-09-28 13:00:14 EDT

Note You need to log in before you can comment on or make changes to this bug.