Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1573073 - Konsole ignore scrollback settings
Summary: Konsole ignore scrollback settings
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: konsole5
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rex Dieter
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 06:23 UTC by Jordan Metzmeier
Modified: 2018-04-30 15:29 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-30 15:29:09 UTC
Type: Bug


Attachments (Terms of Use)

Description Jordan Metzmeier 2018-04-30 06:23:59 UTC
Description of problem:

Adjusting the scrollback settings in konsole does not change the default lines kept via scrollback. I switched from Debian to Fedora last Fall, and Fedora is the the only distro I have experienced this issue.

Version-Release number of selected component (if applicable):

17.12.2-2.fc28

I also experienced this issue on fc27.

How reproducible:

Easily.


Steps to Reproduce:
1. Change scrollback to a fixed scrollback > 1000 or unlimited scrollback
2. Run a command with > 1000 lines of scrollback


Actual results:

Only the default number of lines of scrollback are displayed (I am not sure of the exact number).


Expected results:

Scrollback should go as far back as set. Either unlimited, or the number input as "fixed".

Comment 1 Rex Dieter 2018-04-30 14:14:49 UTC
The only change fedora makes to stock configuration is to set
scrollbackUseCacheLocation
to true by default, ie,
settings -> configure konsole -> file location -> use user specific location
(but that's only relevant if one uses unlimited scrollback).

That said, I cannot reproduce.

I create a new profile, set scroll back to 2000, then select
File -> new tab -> new profile

and run,
for i in {1..2000} ; do echo $i; done;
and my scrollback includes all of it.

Comment 2 Jordan Metzmeier 2018-04-30 15:01:12 UTC
I can see that default is set to ~/.cache/konsole. I checked that directory on my machine, and it is empty. I just tried changing that to /tmp and restarting konsole, but no new file was created in /tmp. Running "for i in {1..2000} ; do echo $i; done;" only scrolls back to "931".

Thanks for looking into the issue.

Comment 3 Rex Dieter 2018-04-30 15:06:46 UTC
FYI, that custom dir is only used if you set *unlimited* scrollback, otherwise, it's save in memory

Comment 4 Jordan Metzmeier 2018-04-30 15:09:11 UTC
I was actually able to resolve the issue by creating a new profile and switching to that (without any changes). When I switch back to the original profile it still works. I assume for some reason it wasn't using any profile. Since this looks like an issue on my end, we can close this bug. Thanks for the help.

Comment 5 Rex Dieter 2018-04-30 15:29:09 UTC
OK, thanks for the additional testing too


Note You need to log in before you can comment on or make changes to this bug.