Bug 1573093 - SIGARBT when using astyle with --recursive
Summary: SIGARBT when using astyle with --recursive
Keywords:
Status: CLOSED DUPLICATE of bug 1573092
Alias: None
Product: Fedora
Classification: Fedora
Component: astyle
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Jens Lody
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 07:54 UTC by Andrew Hutchings
Modified: 2018-04-30 09:12 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-04-30 09:12:16 UTC
Type: Bug


Attachments (Terms of Use)

Description Andrew Hutchings 2018-04-30 07:54:32 UTC
Description of problem:
astyle with SIGABRT in Fedora 28 when --recursive is used. Works fine in Fedora 27.

Version-Release number of selected component (if applicable):
astyle-3.1-3.fc28.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Go to a directory with some .c and .h files
2. Execute: astyle --recursive "*.c" "*.h"

Actual results:
Directory  /home/linuxjedi/Programming/Git/libattachsql/*.c
/usr/include/c++/8/bits/stl_vector.h:932: std::vector<_Tp, _Alloc>::reference std::vector<_Tp, _Alloc>::operator[](std::vector<_Tp, _Alloc>::size_type) [with _Tp = std::__cxx11::basic_string<char>; _Alloc = std::allocator<std::__cxx11::basic_string<char> >; std::vector<_Tp, _Alloc>::reference = std::__cxx11::basic_string<char>&; std::vector<_Tp, _Alloc>::size_type = long unsigned int]: Assertion '__builtin_expect(__n < this->size(), true)' failed.
Aborted (core dumped)

Expected results:
No crash

Additional info:
As a workaround I downgraded to astyle-3.0.1-4.fc27.x86_64 which works fine.

Comment 1 Mamoru TASAKA 2018-04-30 09:12:16 UTC

*** This bug has been marked as a duplicate of bug 1573092 ***


Note You need to log in before you can comment on or make changes to this bug.