Bug 15731 - Setting japanese locale, causes all OS commands to fail
Summary: Setting japanese locale, causes all OS commands to fail
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: locale-ja   
(Show other bugs)
Version: 7.0
Hardware: All Linux
high
high
Target Milestone: ---
Assignee: Matt Wilson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-08-08 15:32 UTC by Need Real Name
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-29 13:20:54 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2000-08-08 15:32:12 UTC
Installed a mostly default english version of Pinstripe Beta-3 and also
Beta-5

If you run:
  
  1. export LANG=japanese   (valid language as listed by a "locale -a" ) 
  2. date
  
  On Beta-3 I get:
  Tue Aug  8 10:33:07 BST 2000
  
  On Beta-5 I get:
  date: loadlocale.c:220: _nl_load_locale: Assertion `idx % 4 == 0' failed.
  Aborted
  
  Now the behaviour I got on Beta-3 seems plausible, i.e. it thinks that
  japanese is not a valid locale, and reverts to using "C". I would have
  preferred to have seen some funny japanese characters in the date string
  but I am not too concerned since it does not prevent anything else from
  working.
  
  The behaviour on Beta-5 is more worrying - since I get this error for any
  OS command I run e.g. "ls".

Comment 1 Matt Wilson 2000-08-08 21:22:13 UTC
you need to rebuild the locale-ja package from the src.rpm using "rpm
--rebuild".  After installing the resulting binary package, the Japanese locale
will work again.

This has been fixed here for quite some time.


Comment 2 Need Real Name 2000-08-29 13:20:52 UTC
So can you confirm that this is not going to be a problem in the final RedHat7.0
release ? - or will everyone have to download and re-compile the source ?

Comment 3 Matt Wilson 2000-08-29 15:33:58 UTC
oh, of course this won't be a problem in final - Japanese support would be
totally broken.

The locale def is in the glibc package now, so if the binary format ever changes
again there won't be problems.



Note You need to log in before you can comment on or make changes to this bug.