Bug 1573112 - Screen flickering on Intel HD 620 after upgrade to 4.16.4
Summary: Screen flickering on Intel HD 620 after upgrade to 4.16.4
Keywords:
Status: CLOSED DUPLICATE of bug 1573482
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-intel
Version: 27
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Adam Jackson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 08:24 UTC by Julien
Modified: 2018-05-01 14:51 UTC (History)
20 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-01 14:51:53 UTC
Type: Bug


Attachments (Terms of Use)

Description Julien 2018-04-30 08:24:39 UTC
Description of problem:
After upgrading the kernel from 4.15.15-300.fc27 to 4.16.4-200.fc27, the screen (both internal or hdmi external) exhibits important flickering. Everything is fine with kernel 4.15.15.

How reproducible:
Always

Steps to Reproduce:
1. boot kernel version 4.16.4-200.fc27
2. login to wayland

Actual results:
The screen flickers

Expected results:
No flickering

Additional info:

GPU : Intel HD Graphics 620 (Kaby Lake GT2)
CPU : Core i7-7500U

I've been running with i915.enable_rc6=0 for the last few month, and the flickering looks similar to the one present when running with RC6 enabled. Enabling/disabling RC6 on the 4.16.4 kernel does not change the behaviour.

Comment 1 Jeremy Cline 2018-04-30 14:21:45 UTC
Hi Julien,

Thanks for the report, I'm moving this to the Intel driver component since we track graphics related problems there. Some first steps for debugging would be to check whether this is present in the Rawhide kernel. If it is, bisecting would be very helpful.

Comment 2 Julien 2018-04-30 14:29:20 UTC
Thanks Jeremy.

I'll try the rawhide kernel and report back here. I'm not sure what you mean by "bisecting", but I'll do what I can to help.

Comment 3 Jeremy Cline 2018-04-30 16:46:50 UTC
Ah, excellent, I've been looking for someone to walk through the guide on bisecting!

Documentation on how to bisect the kernel is at https://docs.fedoraproject.org/quick-docs/en-US/kernel/troubleshooting.html#bisecting-the-kernel. If anything isn't clear, or you get stuck for some reason, please let me know.

Comment 4 Jeremy Cline 2018-05-01 14:51:53 UTC
In https://bugzilla.redhat.com/show_bug.cgi?id=1573482 Laura notes i915.enable_rc6 was removed intentionally so I'm guessing that's the root cause of your issue. It would be best to report this upstream to bugzilla.freedesktop.org (or add to the report from Klaus if they file a bug), then link it back to #1573482.

*** This bug has been marked as a duplicate of bug 1573482 ***


Note You need to log in before you can comment on or make changes to this bug.