Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1573119 - Amends in volume profile option 'gluster-block'
Summary: Amends in volume profile option 'gluster-block'
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: core
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Prasanna Kumar Kalever
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks: 1569951
TreeView+ depends on / blocked
 
Reported: 2018-04-30 08:38 UTC by Pranith Kumar K
Modified: 2018-06-20 18:05 UTC (History)
9 users (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of: 1569951
Environment:
Last Closed: 2018-06-20 18:05:40 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Comment 1 Pranith Kumar K 2018-04-30 08:40:23 UTC
Eager-lock is now giving better performance in block after (https://github.com/gluster/glusterfs/issues/418) so it is advised to use eager-lock on with the newer versions of gluster-block.

Comment 2 Worker Ant 2018-04-30 08:49:23 UTC
REVIEW: https://review.gluster.org/19913 (block-profile: enable cluster.eager-lock in block-profile) posted (#2) for review on master by Pranith Kumar Karampuri

Comment 3 Worker Ant 2018-05-01 12:23:14 UTC
COMMIT: https://review.gluster.org/19913 committed in master by "Niels de Vos" <ndevos@redhat.com> with a commit message- block-profile: enable cluster.eager-lock in block-profile

Eager-lock gave 2.5X perf improvement. On top of that with batching
fix in tcmu-runner and client-io-threads we are seeing close to 3X perf
improvement. But we don't want to include that in the default profile
option but enable it on a case by case basis. So not adding
client-io-threads option.

BUG: 1573119
Fixes: bz#1573119
Change-Id: Ida53c3ef9a041a73b65fdd06158ac082da437206
Signed-off-by: Prasanna Kumar Kalever <prasanna.kalever@redhat.com>

Comment 4 Shyamsundar 2018-06-20 18:05:40 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.