Bug 1573124 - NFS Minor version specified in fstab is ignored
Summary: NFS Minor version specified in fstab is ignored
Keywords:
Status: CLOSED DUPLICATE of bug 1547506
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: nfs-utils
Version: 7.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Steve Dickson
QA Contact: Yongcheng Yang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 09:05 UTC by Yves Couèque
Modified: 2018-05-02 02:30 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 02:30:25 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Yves Couèque 2018-04-30 09:05:27 UTC
Description of problem:
With current version of nfs-utils, NFSv4.1 is the default.
NFS minor version 0 is ignored when specified in fstab on NFS client.
Client is trying NFSv4.1 anyway.


Version-Release number of selected component (if applicable):
Name        : nfs-utils
Arch        : x86_64
Epoch       : 1
Version     : 1.3.0
Release     : 0.48.el7_4.2




How reproducible:
100%


Steps to Reproduce:

1. /etc/fstab:
10.30.100.220:/FRA2-MS-UNI001_GG_91132_NFS_T1_01/mqm /mqshare nfs4 rw,bg,hard,intr,vers=4,minorversion=0,sec=sys,addr=10.30.100.220 0 0

2. mount -a

3. mount -t nfs4

4. umount /mqshare

5. /etc/fstab:
10.30.100.220:/FRA2-MS-UNI001_GG_91132_NFS_T1_01/mqm /mqshare nfs4 rw,bg,hard,intr,vers=4.0,sec=sys,addr=10.30.100.220 0 0

6. mount -a

7. mount -t nfs4

Actual results:

First 'mount -t nfs4':
10.30.100.220:/FRA2-MS-UNI001_GG_91132_NFS_T1_01/mqm on /mqshare type nfs4 (rw,relatime,vers=4.1,rsize=262144,wsize=262144,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=10.30.100.11,local_lock=none,addr=10.30.100.220)

Second 'mount -t nfs4':
10.30.100.220:/FRA2-MS-UNI001_GG_91132_NFS_T1_01/mqm on /mqshare type nfs4 (rw,relatime,vers=4.1,rsize=262144,wsize=262144,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=10.30.100.11,local_lock=none,addr=10.30.100.220)


Expected results:

10.30.100.220:/FRA2-MS-UNI001_GG_91132_NFS_T1_01/mqm on /mqshare type nfs4 (rw,relatime,vers=4.0,rsize=262144,wsize=262144,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=10.30.100.11,local_lock=none,addr=10.30.100.220)


Additional info:

Mounting manualy results in NFSv4.0.

# mount.nfs -vvvv -overs=4.0 10.30.100.220:/FRA2-MS-UNI001_GG_91132_NFS_T1_01/mqm /mqshare nfs4
mount.nfs: timeout set for Mon Apr 30 10:59:46 2018
mount.nfs: trying text-based options 'vers=4.0,addr=10.30.100.220,clientaddr=10.30.100.11'
# mount -t nfs4
10.30.100.220:/FRA2-MS-UNI001_GG_91132_NFS_T1_01/mqm on /mqshare type nfs4 (rw,relatime,vers=4.0,rsize=262144,wsize=262144,namlen=255,hard,proto=tcp,port=0,timeo=600,retrans=2,sec=sys,clientaddr=10.30.100.11,local_lock=none,addr=10.30.100.220)

Comment 2 Yongcheng Yang 2018-05-02 02:30:25 UTC
(In reply to Yves Couèque from comment #0)

Hi Yves, thanks for the bug reporting.

This problem has already been fixed in Bug 1547506.  And it has also been
back-ported to RHEL-7.4 in nfs-utils-1.3.0-0.48.el7_4.3 now.

Please update your nfs-utils package to "0.48.el7_4.3" (or beyond) and
try it again.

> Description of problem:
> With current version of nfs-utils, NFSv4.1 is the default.
> NFS minor version 0 is ignored when specified in fstab on NFS client.
> Client is trying NFSv4.1 anyway.
> 
> 
> Version-Release number of selected component (if applicable):
> Name        : nfs-utils
> Arch        : x86_64
> Epoch       : 1
> Version     : 1.3.0
> Release     : 0.48.el7_4.2

Just closing this one for now. Feel free to reopen if there's anything new.

*** This bug has been marked as a duplicate of bug 1547506 ***


Note You need to log in before you can comment on or make changes to this bug.