Bug 1573216 - non-VM network appears in the new vNIC profile drop down
Summary: non-VM network appears in the new vNIC profile drop down
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine
Classification: oVirt
Component: BLL.Network
Version: 4.2.3.2
Hardware: x86_64
OS: Linux
high
medium vote
Target Milestone: ovirt-4.2.4
: ---
Assignee: Ales Musil
QA Contact: Michael Burman
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 14:02 UTC by Michael Burman
Modified: 2018-06-26 08:44 UTC (History)
3 users (show)

Fixed In Version: ovirt-engine-4.2.4
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:44:25 UTC
oVirt Team: Network
rule-engine: ovirt-4.2+
ylavi: blocker+


Attachments (Terms of Use)
record (2.23 MB, application/x-gzip)
2018-04-30 14:09 UTC, Michael Burman
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 90869 master MERGED webadmin: Fix non-VM network apearing in new vnic profile 2018-05-07 11:57:45 UTC
oVirt gerrit 90971 ovirt-engine-4.2 MERGED webadmin: Fix non-VM network apearing in new vnic profile 2018-05-09 08:47:44 UTC

Description Michael Burman 2018-04-30 14:02:11 UTC
Description of problem:
non-VM network appears in the new vNIC profile drop down .

When creating non-VM network, it has no vNIC profile, but when going to the vNIC profiles tab, this network is appears in the new vNIC profile drop down list, but it shouldn't, because this network is a non-VM network. When trying to create new vNIC profile to this network we fail with error validation:

"Error while executing action: Cannot add VM network interface profile. VM network interface profiles cannot be added to a non-VM network. Please make sure the network is a VM network."

Version-Release number of selected component (if applicable):
4.2.3.3-0.1.el7

How reproducible:
100%

Steps to Reproduce:
1. Create non-VM network net1 
2. Go to vNIC profile tab 
3. net1 appears in the drop down list for new vNIC profile

Actual results:
net1 is available for new vNIC profile

Expected results:
net1 is a non-VM network and should not be available for new vNIC profile creation

Comment 1 Michael Burman 2018-04-30 14:09:24 UTC
Created attachment 1428837 [details]
record

Comment 2 Dan Kenigsberg 2018-04-30 20:45:19 UTC
Michael, can you tell which Engine version introduced this regression?

Ales, could this be a very recent regression due removing OvS networks from this list?

Comment 3 Michael Burman 2018-05-01 05:35:02 UTC
(In reply to Dan Kenigsberg from comment #2)
> Michael, can you tell which Engine version introduced this regression?
> 
> Ales, could this be a very recent regression due removing OvS networks from
> this list?

I think this bug is exist from the very beginning of the new UI re-design. Because on 4.1 and older versions we didn't had such option or flow.
In the new UI in 4.2 we have a new vNIC profile tab and such flow is possible and it's why i think it don't a regression bug. I have missed this flow in 4.2 until now. 

BTW, what do you mean removing ovs networks from this list?(i'm not aware of this), how can you know if it's an ovs network?(because it's in an ovs cluster?)

Comment 4 Ales Musil 2018-05-03 08:27:43 UTC
This is not affected by the auto-define. The auto-define is not yet in d/s build as well as auto-define did not touch this part of flow. I agree with Micheal that this is caused by the redesign.

Comment 5 Michael Burman 2018-05-27 07:56:13 UTC
Verified on - 4.2.4-0.1.el7

Comment 6 Sandro Bonazzola 2018-06-26 08:44:25 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.