Bug 1573220 - Memory leak in volume tier status command
Summary: Memory leak in volume tier status command
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: glusterd
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Sanju
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 14:09 UTC by Sanju
Modified: 2020-01-09 17:45 UTC (History)
1 user (show)

Fixed In Version: glusterfs-v4.1.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-20 18:05:40 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Sanju 2018-04-30 14:09:57 UTC
Description of problem:
If we execute gluster volume tier <volname> status in a loop, glusterd's memory is increasing heavily.

Version-Release number of selected component (if applicable):


How reproducible:
1/1

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:
glusterd's memory should not grow significantly.

Additional info:

Comment 1 Worker Ant 2018-04-30 14:12:18 UTC
REVIEW: https://review.gluster.org/19950 (glusterd: Fix for memory leak in volume tier status command) posted (#1) for review on master by Sanju Rakonde

Comment 2 Worker Ant 2018-05-06 06:28:26 UTC
COMMIT: https://review.gluster.org/19950 committed in master by "Amar Tumballi" <amarts@redhat.com> with a commit message- glusterd: Fix for memory leak in volume tier status command

Fixes: bz#1573220
Change-Id: Ia60f40fa4f1e525cae6f571a24e5385ba1e004c0
Signed-off-by: Sanju Rakonde <srakonde@redhat.com>

Comment 3 Shyamsundar 2018-06-20 18:05:40 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-v4.1.0, please open a new bug report.

glusterfs-v4.1.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://lists.gluster.org/pipermail/announce/2018-June/000102.html
[2] https://www.gluster.org/pipermail/gluster-users/


Note You need to log in before you can comment on or make changes to this bug.