Bug 1573237 - Fix amphora failover: add timestamps
Summary: Fix amphora failover: add timestamps
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-octavia
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
urgent
high
Target Milestone: z1
: 13.0 (Queens)
Assignee: Carlos Goncalves
QA Contact: Alexander Stafeyev
URL:
Whiteboard:
Depends On:
Blocks: 1433523 1571654
TreeView+ depends on / blocked
 
Reported: 2018-04-30 14:52 UTC by Carlos Goncalves
Modified: 2019-09-10 14:10 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-27 20:03:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
OpenStack gerrit 547967 0 None master: MERGED octavia: Add timestamps to amphora table (I3df39278eee2d2c6c31f93c8b651e6f74690a1b1) 2018-05-14 10:25:59 UTC

Description Carlos Goncalves 2018-04-30 14:52:37 UTC
Description of problem:

Amphora failover may be triggered for already failed amphora failover. The open patch that fixes the issue is [1] and relies on [2]. We request patch [2] to be included in GA release because it adds new columns to the database table, which cannot be added post deployment simply via package update.

[1] https://review.openstack.org/#/c/548989/
[2] https://review.openstack.org/#/c/547967

Comment 6 Carlos Goncalves 2018-06-27 20:03:41 UTC
OSP13 GA is out. Patch would require altering database schema which we don't do in ZStream. Patch will be included in OSP14 (Rocky-based).


Note You need to log in before you can comment on or make changes to this bug.