Bug 1573242 - After logging back in, the page is blank
Summary: After logging back in, the page is blank
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-tripleo-ui
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Honza Pokorny
QA Contact: Arik Chernetsky
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 15:05 UTC by Udi
Modified: 2019-05-16 16:03 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-05-16 16:03:21 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Udi 2018-04-30 15:05:05 UTC
Description of problem:
If you get logged out of the GUI (after 4 hours when your token expires) and log back in, you get a blank white page and have to press F5 to get the deployment page.


Version-Release number of selected component (if applicable):
openstack-tripleo-ui-8.3.1-2.el7ost.noarch


How reproducible:
100%


Steps to Reproduce:
1. Get logged out due to a token expiration
2. Log back in


Actual results:
You're logged in but the page doesn't load.

Comment 6 Jason E. Rist 2018-10-30 15:24:35 UTC
If you get this again will you please update the bug with console output.

Comment 7 Udi 2018-10-31 09:53:46 UTC
You see this repeated in the console numerous times:

WebSocket is already in CLOSING or CLOSED state.
(anonymous) @ tripleo_ui.js:1
(anonymous) @ tripleo_ui.js:1
dispatch @ tripleo_ui.js:1
(anonymous) @ tripleo_ui.js:1
(anonymous) @ tripleo_ui.js:1
value @ tripleo_ui.js:1
(anonymous) @ tripleo_ui.js:1
value @ tripleo_ui.js:1
(anonymous) @ tripleo_ui.js:1
value @ tripleo_ui.js:1
t.(anonymous function) @ tripleo_ui.js:1
(anonymous) @ tripleo_ui.js:1
g @ tripleo_ui.js:1
(anonymous) @ tripleo_ui.js:1
(anonymous) @ tripleo_ui.js:1
(anonymous) @ tripleo_ui.js:1
s.register @ tripleo_ui.js:1
value @ tripleo_ui.js:1
ca @ tripleo_ui.js:1
Fa @ tripleo_ui.js:1
fi @ tripleo_ui.js:1
hi @ tripleo_ui.js:1
Qi @ tripleo_ui.js:1
Wi @ tripleo_ui.js:1
Hi @ tripleo_ui.js:1
nl @ tripleo_ui.js:1
Fn @ tripleo_ui.js:1

Recreated on openstack-tripleo-ui-9.3.1-0.20180921180341.df30b55.el7ost.noarch

Comment 8 Beth White 2019-05-16 16:03:21 UTC
The GUI is no longer supported in OSP14. The last supported release for the GUI is OSP13. Closing as won't fix.


Note You need to log in before you can comment on or make changes to this bug.