Bug 1573243 - Can't edit users when using LDAP datasource
Summary: Can't edit users when using LDAP datasource
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: LDAP
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: Daniel Lobato Garcia
QA Contact: Kedar Bidarkar
URL:
Whiteboard:
: 1584455 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 15:05 UTC by Suraj Patil
Modified: 2021-06-10 16:01 UTC (History)
7 users (show)

Fixed In Version: foreman-1.15.6.47-1
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1596345 (view as bug list)
Environment:
Last Closed: 2018-08-22 20:07:08 UTC
Target Upstream Version:


Attachments (Terms of Use)
screenshot of the issue (88.71 KB, image/png)
2018-04-30 15:05 UTC, Suraj Patil
no flags Details
1573243_bz.patch (1.79 KB, patch)
2018-06-15 17:19 UTC, Waldirio M Pinheiro
no flags Details | Diff
Before and After patch applied (242.93 KB, application/pdf)
2018-06-15 17:23 UTC, Waldirio M Pinheiro
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Foreman Issue Tracker 13749 0 Normal Closed Getting avatar from openldap seems to be broken 2020-04-14 05:56:28 UTC

Description Suraj Patil 2018-04-30 15:05:13 UTC
Created attachment 1428846 [details]
screenshot of the issue

Description of problem:

When satellite is configured with LDAP (AD server), users photo is not displayed.


How reproducible:

Configure LDAP AD server with satellite. Make sure to put photo attribute = thumbnailPhoto while configuring LDAP.

After configuring LDAP, login to the satellite using AD user.

Actual results:
corrupted image 

Expected results:
User photo should appear in the top right corner and in Administer > Users

Additional info:

Upstream bug - https://projects.theforeman.org/issues/13749

Comment 4 Waldirio M Pinheiro 2018-05-31 02:00:10 UTC
*** Bug 1584455 has been marked as a duplicate of this bug. ***

Comment 7 Daniel Lobato Garcia 2018-05-31 14:23:05 UTC
https://github.com/theforeman/foreman/pull/5630 PR is submitted upstream, waiting on review.

Comment 10 pm-sat@redhat.com 2018-06-07 16:04:40 UTC
Moving this bug to POST for triage into Satellite 6 since the upstream issue http://projects.theforeman.org/issues/13749 has been resolved.

Comment 20 Waldirio M Pinheiro 2018-06-15 17:19:04 UTC
Created attachment 1452005 [details]
1573243_bz.patch

Comment 21 Waldirio M Pinheiro 2018-06-15 17:23:35 UTC
Created attachment 1452006 [details]
Before and After patch applied

Comment 24 Kedar Bidarkar 2018-08-01 10:48:57 UTC
Followed the below steps to verify this bug:

Made use of Powershell commands to download and upload photo to user attribute "thumbnailPhoto".

On AD Server:

1) Downloaded photo:
$client = new-object System.Net.WebClient
$client.DownloadFile(“http://example.com/pub/thumbnailphoto.jpg”,“C:\Users\Administrator\Pictures\thumbnailphot.jpg”)


2) Uploaded photo:
$photo = [byte[]](Get-Content C:\Users\Administrator\Pictures\thumbnailphoto.jpg -Encoding byte)
Set-ADUser foobar -Replace @{thumbnailPhoto=$photo}

On Satellite6 Server:

1) On Create LDAP Auth source page of "attribute mappings" Tab do:

Photo attribute: thumbnailPhoto


Verified with Sat6.3.3 snap2

Comment 25 Kedar Bidarkar 2018-08-01 10:50:51 UTC
The photo added to user "foobar" on AD Server appeared automatically in the top right corner of Administer > Users.

Comment 27 errata-xmlrpc 2018-08-22 20:07:08 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:2550


Note You need to log in before you can comment on or make changes to this bug.