Bug 1573269 - RHOSP documentation should describe how to properly configure GPU passthrough
Summary: RHOSP documentation should describe how to properly configure GPU passthrough
Keywords:
Status: CLOSED DUPLICATE of bug 1430337
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-nova
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: ---
Assignee: nova-maint
QA Contact: nova-maint
URL:
Whiteboard:
Depends On:
Blocks: bu-gpu-crash
TreeView+ depends on / blocked
 
Reported: 2018-04-30 17:20 UTC by Lars Kellogg-Stedman
Modified: 2019-09-09 13:54 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 00:41:58 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Lars Kellogg-Stedman 2018-04-30 17:20:15 UTC
Description of problem:

Our existing documentation [1] and the upstream Nova documentation [2] describes how to configure PCI passthrough in general.  Unfortunately, neither source of documentation references the additional steps necessary to properly configure passthrough of a GPU device.

[1]: https://access.redhat.com/solutions/3260061
[2]: https://docs.openstack.org/nova/pike/admin/pci-passthrough.html

Our standard kernel package ships with the "nouveau" driver, which will automatically bind to any available nvidia GPUs when the system boots.  This can cause conflicts with guests that attempt to access the GPU at the same time.

The proper instructions can actually be found in our "Virtualization Deployment and Administration Guide" [3], but they are buried in the section on the vGPU feature when in fact that are required for any GPU passhthrough.

[3]: https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/7/html/virtualization_deployment_and_administration_guide/sect-device-gpu#sect-device-GPU-vGPU

Our OpenStack documentation should provide a summary of these instructions for people who wish to configure GPU passthrough for their Nova servers.

Version-Release number of selected component (if applicable):

RHEL-OSP 12 (and later)

Comment 1 Lars Kellogg-Stedman 2018-05-02 00:41:58 UTC

*** This bug has been marked as a duplicate of bug 1430337 ***


Note You need to log in before you can comment on or make changes to this bug.