Bug 1573273 - [Infra] Cannot edit match metadata (and/or possibly other errors) due to the "frozen class (cannot edit)" problem
Summary: [Infra] Cannot edit match metadata (and/or possibly other errors) due to the ...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: opendaylight
Version: 13.0 (Queens)
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: z1
: 13.0 (Queens)
Assignee: Michael Vorburger
QA Contact: Itzik Brown
URL:
Whiteboard: Infra
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 17:26 UTC by Janki
Modified: 2018-10-25 05:21 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
The problem which is logged as "frozen class (cannot edit)" may be simply due to the use of an internal debugging tool (known as odl-mdsal-trace), and should not affect customers.
Clone Of:
Environment:
N/A
Last Closed: 2018-06-12 12:56:44 UTC
Target Upstream Version:


Attachments (Terms of Use)
karaf.log (1.41 MB, text/plain)
2018-05-03 09:18 UTC, Janki
no flags Details


Links
System ID Private Priority Status Summary Last Updated
OpenDaylight Bug CONTROLLER-1832 0 None None None 2018-06-06 10:10:38 UTC
OpenDaylight Bug CONTROLLER-1834 0 None None None 2018-06-06 10:15:45 UTC
OpenDaylight Bug MDSAL-213 0 None None None 2018-05-08 09:37:51 UTC
OpenDaylight gerrit 71890 0 None None None 2018-05-14 14:03:48 UTC
OpenDaylight gerrit 72715 0 None None None 2018-06-06 10:11:11 UTC
OpenDaylight gerrit 72716 0 None None None 2018-06-06 10:13:43 UTC

Description Janki 2018-04-30 17:26:32 UTC
Description of problem:


Version-Release number of selected component (if applicable):
ODL rpm 8.0.0.8

How reproducible:
Always

Steps to Reproduce:
1. Deploy ODL 8.0.0.8 + OSP

Additional info:
2018-04-30T15:08:33,051 | ERROR | org.opendaylight.yang.gen.v1.urn.opendaylight.flow.inventory.rev130819.FlowCapableNode_AsyncClusteredDataTreeChangeListenerBase-DataTreeChangeHandler-0 | AsyncClusteredDataTreeChangeListenerBase | 263 - org.opendaylight.genius.mdsalutil-api - 0.4.0.redhat-8 | Thread terminated due to uncaught exception: org.opendaylight.yang.gen.v1.urn.opendaylight.flow.inventory.rev130819.FlowCapableNode_AsyncClusteredDataTreeChangeListenerBase-DataTreeChangeHandler-0
com.google.common.util.concurrent.UncheckedExecutionException: com.google.common.util.concurrent.UncheckedExecutionException: com.google.common.util.concurrent.UncheckedExecutionException: com.google.common.util.concurrent.UncheckedExecutionException: java.lang.RuntimeException: org.opendaylight.yang.gen.v1.urn.opendaylight.model.match.types.rev131026.match.Metadata$StreamWriter: frozen class (cannot edit)
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2218) [32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.get(LocalCache.java:4147) [32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:4151) [32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:5140) [32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:5146) [32:com.google.guava:23.3.0.jre]
    at org.opendaylight.mdsal.binding.dom.codec.impl.BindingNormalizedNodeCodecRegistry.getSerializer(BindingNormalizedNodeCodecRegistry.java:72) [290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.impl.BindingNormalizedNodeCodecRegistry.toNormalizedNode(BindingNormalizedNodeCodecRegistry.java:107) [290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.controller.md.sal.binding.impl.BindingToNormalizedNodeCodec.toNormalizedNode(BindingToNormalizedNodeCodec.java:134) [220:org.opendaylight.controller.sal-binding-broker-impl:1.7.0.redhat-8]
    at org.opendaylight.controller.md.sal.binding.impl.AbstractWriteTransaction.put(AbstractWriteTransaction.java:39) [220:org.opendaylight.controller.sal-binding-broker-impl:1.7.0.redhat-8]
    at org.opendaylight.genius.mdsalutil.internal.MDSALManager.writeFlowEntityInternal(MDSALManager.java:183) [264:org.opendaylight.genius.mdsalutil-impl:0.4.0.redhat-8]
    at org.opendaylight.genius.mdsalutil.internal.MDSALManager.installFlowInternal(MDSALManager.java:142) [264:org.opendaylight.genius.mdsalutil-impl:0.4.0.redhat-8]
    at org.opendaylight.genius.mdsalutil.internal.MDSALManager.installFlow(MDSALManager.java:609) [264:org.opendaylight.genius.mdsalutil-impl:0.4.0.redhat-8]
    at Proxydde4f757_0177_4930_af4f_a514886e67a6.installFlow(Unknown Source) [?:?]
    at Proxy12933f77_31f6_4e8b_b7ca_4582b0b424a9.installFlow(Unknown Source) [?:?]
    at org.opendaylight.netvirt.ipv6service.Ipv6NodeListener.createTableMissEntry(Ipv6NodeListener.java:91) [356:org.opendaylight.netvirt.ipv6service-impl:0.6.0.redhat-8]
    at org.opendaylight.netvirt.ipv6service.Ipv6NodeListener.add(Ipv6NodeListener.java:74) [356:org.opendaylight.netvirt.ipv6service-impl:0.6.0.redhat-8]
    at org.opendaylight.netvirt.ipv6service.Ipv6NodeListener.add(Ipv6NodeListener.java:36) [356:org.opendaylight.netvirt.ipv6service-impl:0.6.0.redhat-8]
    at org.opendaylight.genius.datastoreutils.AsyncClusteredDataTreeChangeListenerBase$DataTreeChangeHandler.run(AsyncClusteredDataTreeChangeListenerBase.java:155) [263:org.opendaylight.genius.mdsalutil-api:0.4.0.redhat-8]
    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149) [?:?]
    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624) [?:?]
    at java.lang.Thread.run(Thread.java:748) [?:?]
  Caused by: com.google.common.util.concurrent.UncheckedExecutionException: com.google.common.util.concurrent.UncheckedExecutionException: com.google.common.util.concurrent.UncheckedExecutionException: java.lang.RuntimeException: org.opendaylight.yang.gen.v1.urn.opendaylight.model.match.types.rev131026.match.Metadata$StreamWriter: frozen class (cannot edit)
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2218) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.get(LocalCache.java:4147) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:4151) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:5140) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:5146) ~[32:com.google.guava:23.3.0.jre]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.getSerializer(AbstractStreamWriterGenerator.java:87) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.impl.BindingNormalizedNodeCodecRegistry$GeneratorLoader.load(BindingNormalizedNodeCodecRegistry.java:283) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.impl.BindingNormalizedNodeCodecRegistry$GeneratorLoader.load(BindingNormalizedNodeCodecRegistry.java:280) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3708) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2416) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2299) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2212) ~[32:com.google.guava:23.3.0.jre]
    ... 20 more
  Caused by: com.google.common.util.concurrent.UncheckedExecutionException: com.google.common.util.concurrent.UncheckedExecutionException: java.lang.RuntimeException: org.opendaylight.yang.gen.v1.urn.opendaylight.model.match.types.rev131026.match.Metadata$StreamWriter: frozen class (cannot edit)
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2218) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.get(LocalCache.java:4147) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:4151) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:5140) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:5146) ~[32:com.google.guava:23.3.0.jre]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.loadSerializerFor(AbstractStreamWriterGenerator.java:97) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataObjectSerializerSource.staticInvokeEmitter(DataObjectSerializerSource.java:144) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitChildInner(DataNodeContainerSerializerSource.java:184) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitChild(DataNodeContainerSerializerSource.java:158) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitBody(DataNodeContainerSerializerSource.java:148) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.getSerializerBody(DataNodeContainerSerializerSource.java:83) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.lambda$generateEmitter0$0(AbstractStreamWriterGenerator.java:205) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.yangtools.util.ClassLoaderUtils.withClassLoader(ClassLoaderUtils.java:51) ~[425:org.opendaylight.yangtools.util:2.0.1.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.generateEmitter0(AbstractStreamWriterGenerator.java:204) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.access$300(AbstractStreamWriterGenerator.java:45) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.generateSerializer(AbstractStreamWriterGenerator.java:138) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:124) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:100) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3708) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2416) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2299) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2212) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.get(LocalCache.java:4147) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:4151) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:5140) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:5146) ~[32:com.google.guava:23.3.0.jre]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.getSerializer(AbstractStreamWriterGenerator.java:87) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.impl.BindingNormalizedNodeCodecRegistry$GeneratorLoader.load(BindingNormalizedNodeCodecRegistry.java:283) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.impl.BindingNormalizedNodeCodecRegistry$GeneratorLoader.load(BindingNormalizedNodeCodecRegistry.java:280) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3708) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2416) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2299) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2212) ~[32:com.google.guava:23.3.0.jre]
    ... 20 more
  Caused by: com.google.common.util.concurrent.UncheckedExecutionException: java.lang.RuntimeException: org.opendaylight.yang.gen.v1.urn.opendaylight.model.match.types.rev131026.match.Metadata$StreamWriter: frozen class (cannot edit)
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2218) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.get(LocalCache.java:4147) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:4151) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:5140) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:5146) ~[32:com.google.guava:23.3.0.jre]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.loadSerializerFor(AbstractStreamWriterGenerator.java:97) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataObjectSerializerSource.staticInvokeEmitter(DataObjectSerializerSource.java:144) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitChildInner(DataNodeContainerSerializerSource.java:184) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitChild(DataNodeContainerSerializerSource.java:158) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitBody(DataNodeContainerSerializerSource.java:148) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.getSerializerBody(DataNodeContainerSerializerSource.java:83) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.lambda$generateEmitter0$0(AbstractStreamWriterGenerator.java:205) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.yangtools.util.ClassLoaderUtils.withClassLoader(ClassLoaderUtils.java:51) ~[425:org.opendaylight.yangtools.util:2.0.1.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.generateEmitter0(AbstractStreamWriterGenerator.java:204) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.access$300(AbstractStreamWriterGenerator.java:45) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.generateSerializer(AbstractStreamWriterGenerator.java:138) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:124) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:100) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3708) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2416) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2299) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2212) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.get(LocalCache.java:4147) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:4151) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:5140) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:5146) ~[32:com.google.guava:23.3.0.jre]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.loadSerializerFor(AbstractStreamWriterGenerator.java:97) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataObjectSerializerSource.staticInvokeEmitter(DataObjectSerializerSource.java:144) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitChildInner(DataNodeContainerSerializerSource.java:184) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitChild(DataNodeContainerSerializerSource.java:158) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitBody(DataNodeContainerSerializerSource.java:148) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.getSerializerBody(DataNodeContainerSerializerSource.java:83) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.lambda$generateEmitter0$0(AbstractStreamWriterGenerator.java:205) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.yangtools.util.ClassLoaderUtils.withClassLoader(ClassLoaderUtils.java:51) ~[425:org.opendaylight.yangtools.util:2.0.1.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.generateEmitter0(AbstractStreamWriterGenerator.java:204) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.access$300(AbstractStreamWriterGenerator.java:45) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.generateSerializer(AbstractStreamWriterGenerator.java:138) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:124) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:100) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3708) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2416) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2299) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2212) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.get(LocalCache.java:4147) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:4151) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:5140) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:5146) ~[32:com.google.guava:23.3.0.jre]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.getSerializer(AbstractStreamWriterGenerator.java:87) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.impl.BindingNormalizedNodeCodecRegistry$GeneratorLoader.load(BindingNormalizedNodeCodecRegistry.java:283) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.impl.BindingNormalizedNodeCodecRegistry$GeneratorLoader.load(BindingNormalizedNodeCodecRegistry.java:280) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3708) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2416) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2299) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2212) ~[32:com.google.guava:23.3.0.jre]
    ... 20 more
  Caused by: java.lang.RuntimeException: org.opendaylight.yang.gen.v1.urn.opendaylight.model.match.types.rev131026.match.Metadata$StreamWriter: frozen class (cannot edit)
    at javassist.ClassPool.checkNotFrozen(ClassPool.java:617) ~[66:javassist:3.21.0.GA]
    at javassist.CtClassType.setName(CtClassType.java:353) ~[66:javassist:3.21.0.GA]
    at javassist.ClassPool.getAndRename(ClassPool.java:408) ~[66:javassist:3.21.0.GA]
    at org.opendaylight.mdsal.binding.generator.util.JavassistUtils.instantiatePrototype(JavassistUtils.java:127) ~[293:org.opendaylight.mdsal.binding-generator-impl:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.generateEmitter0(AbstractStreamWriterGenerator.java:208) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.access$300(AbstractStreamWriterGenerator.java:45) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.generateSerializer(AbstractStreamWriterGenerator.java:138) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:124) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:100) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3708) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2416) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2299) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2212) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.get(LocalCache.java:4147) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:4151) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:5140) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:5146) ~[32:com.google.guava:23.3.0.jre]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.loadSerializerFor(AbstractStreamWriterGenerator.java:97) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataObjectSerializerSource.staticInvokeEmitter(DataObjectSerializerSource.java:144) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitChildInner(DataNodeContainerSerializerSource.java:184) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitChild(DataNodeContainerSerializerSource.java:158) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitBody(DataNodeContainerSerializerSource.java:148) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.getSerializerBody(DataNodeContainerSerializerSource.java:83) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.lambda$generateEmitter0$0(AbstractStreamWriterGenerator.java:205) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.yangtools.util.ClassLoaderUtils.withClassLoader(ClassLoaderUtils.java:51) ~[425:org.opendaylight.yangtools.util:2.0.1.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.generateEmitter0(AbstractStreamWriterGenerator.java:204) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.access$300(AbstractStreamWriterGenerator.java:45) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.generateSerializer(AbstractStreamWriterGenerator.java:138) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:124) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:100) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3708) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2416) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2299) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2212) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.get(LocalCache.java:4147) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:4151) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:5140) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:5146) ~[32:com.google.guava:23.3.0.jre]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.loadSerializerFor(AbstractStreamWriterGenerator.java:97) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataObjectSerializerSource.staticInvokeEmitter(DataObjectSerializerSource.java:144) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitChildInner(DataNodeContainerSerializerSource.java:184) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitChild(DataNodeContainerSerializerSource.java:158) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.emitBody(DataNodeContainerSerializerSource.java:148) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.DataNodeContainerSerializerSource.getSerializerBody(DataNodeContainerSerializerSource.java:83) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.lambda$generateEmitter0$0(AbstractStreamWriterGenerator.java:205) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.yangtools.util.ClassLoaderUtils.withClassLoader(ClassLoaderUtils.java:51) ~[425:org.opendaylight.yangtools.util:2.0.1.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.generateEmitter0(AbstractStreamWriterGenerator.java:204) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.access$300(AbstractStreamWriterGenerator.java:45) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.generateSerializer(AbstractStreamWriterGenerator.java:138) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:124) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator$SerializerImplementationLoader.load(AbstractStreamWriterGenerator.java:100) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3708) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2416) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2299) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2212) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.get(LocalCache.java:4147) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache.getOrLoad(LocalCache.java:4151) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.get(LocalCache.java:5140) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$LocalLoadingCache.getUnchecked(LocalCache.java:5146) ~[32:com.google.guava:23.3.0.jre]
    at org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator.getSerializer(AbstractStreamWriterGenerator.java:87) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.impl.BindingNormalizedNodeCodecRegistry$GeneratorLoader.load(BindingNormalizedNodeCodecRegistry.java:283) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at org.opendaylight.mdsal.binding.dom.codec.impl.BindingNormalizedNodeCodecRegistry$GeneratorLoader.load(BindingNormalizedNodeCodecRegistry.java:280) ~[290:org.opendaylight.mdsal.binding-dom-codec:0.12.0.redhat-8]
    at com.google.common.cache.LocalCache$LoadingValueReference.loadFuture(LocalCache.java:3708) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.loadSync(LocalCache.java:2416) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.lockedGetOrLoad(LocalCache.java:2299) ~[32:com.google.guava:23.3.0.jre]
    at com.google.common.cache.LocalCache$Segment.get(LocalCache.java:2212) ~[32:com.google.guava:23.3.0.jre]
    ... 20 more

Comment 1 Itzik Brown 2018-05-01 07:53:16 UTC
Is there a functional problem?

Comment 2 Janki 2018-05-03 08:49:39 UTC
Yes. It mostly leads to flows missing in table 48.

Comment 3 Janki 2018-05-03 09:18:14 UTC
Created attachment 1430567 [details]
karaf.log

Comment 4 Michael Vorburger 2018-05-03 10:53:18 UTC
This (Caused by: ... frozen class (cannot edit) at javassist.ClassPool.checkNotFrozen) has been seen in the past, but never reliably reproduced, understood, or fixed, see:

* https://jira.opendaylight.org/browse/MDSAL-213
* https://jira.opendaylight.org/browse/MDSAL-230

At the time (over a year ago), if I remember correctly the suspicion was that this could be related to feature reloading / re-installation, but does not happen otherwise.

Comment 7 Michael Vorburger 2018-05-14 14:03:48 UTC
Janki, with https://git.opendaylight.org/gerrit/#/c/71890/ now having been merged upstream into stable/oxygen, please re-run (with an RPM including that) whatever you do which causes frozen yogurt, but please turn up the logging for class org.opendaylight.mdsal.binding.dom.codec.gen.impl.AbstractStreamWriterGenerator all the way up to TRACE and provide the karaf.log of such a run.  Hoping that doesn't lead to too much logged, we'll see; otherwise just do at least DEBUG. (Alternatively, you could configure logigng to for AbstractStreamWriterGenerator to have a separate log file.)

The c/71890 ONLY adds logging, but doesn't actually fix anything; but the next extended logging should help me and upstream friends continue getting a better grip on what is going on there.

Comment 10 Janki 2018-06-04 15:14:43 UTC
I could not reproduce it. But looks like it is seen in upstream CSIT so maybe we can start debugging there.

Comment 11 Michael Vorburger 2018-06-04 16:22:10 UTC
Jamo, hope it's OK that I needinfo this on you re. NETVIRT-1089 for MDSAL-213..

Comment 12 jamo luhrsen 2018-06-04 17:06:27 UTC
(In reply to Michael Vorburger from comment #11)
> Jamo, hope it's OK that I needinfo this on you re. NETVIRT-1089 for
> MDSAL-213..

got it. working on this with an upstream job.

Comment 13 jamo luhrsen 2018-06-04 20:49:39 UTC
(In reply to jamo luhrsen from comment #12)
> (In reply to Michael Vorburger from comment #11)
> > Jamo, hope it's OK that I needinfo this on you re. NETVIRT-1089 for
> > MDSAL-213..
> 
> got it. working on this with an upstream job.

did not see this in one try of the u/s job:
  https://logs.opendaylight.org/releng/vex-yul-odl-jenkins-1/builder-copy-sandbox-logs/89/jamo-traces-netvirt-csit-1node-openstack-queens-upstream-stateful-fluorine/1/odl_1/odl1_karaf.log.gz

Comment 14 Michael Vorburger 2018-06-12 12:56:44 UTC
Despite signficant combined efforts by a number of people, this issue [the "frozen class (cannot edit)" in general, the "match metadata" is just one possible impact] is unable to be reproduced.

There is a chance that the External Trackers linked upstream JIRA issues and Gerrits could have fixed this - that is suspected, but never conclusively proven. If those were it, then this anyway only ever happened due to the internal odl-mdsal-trace Transaction leak debug tool, which would make it a non-issue for real production deployments.

We therefore now close this. Should it be seen again, we should first make sure that *ALL* the External Trackers linked upstream JIRA issues and Gerrits are back-ported, and would need then additional logging as per #c7.


Note You need to log in before you can comment on or make changes to this bug.