Bug 1573323 - 500 Error when provisioned hosts attempts to fetch kickstart file
Summary: 500 Error when provisioned hosts attempts to fetch kickstart file
Keywords:
Status: CLOSED DUPLICATE of bug 1572980
Alias: None
Product: Red Hat Satellite
Classification: Red Hat
Component: Provisioning
Version: 6.4
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: Unspecified
Assignee: satellite6-bugs
QA Contact: Katello QA List
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-04-30 20:36 UTC by Perry Gagne
Modified: 2019-04-01 20:26 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-14 10:19:09 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1572980 0 unspecified CLOSED [sat64] Error rendering the Satellite Kickstart Default Finish template: undefined method '#params' for Host::Managed::J... 2021-02-22 00:41:40 UTC

Internal Links: 1572980

Description Perry Gagne 2018-04-30 20:36:28 UTC
Created attachment 1428953 [details]
Screen shot of provisioned VM

Description of problem: I attempted to provision a PXE booted libvirt host. When the host attempted to fetch the kickstart file, the satellite returned a 500 error (see screenshot)


Version-Release number of selected component (if applicable): 6.4


How reproducible: Always? At Least it is for me.


Steps to Reproduce:
1. Create host using PXE provisioning.

Actual results: 


Expected results: When host attempts to fetch kickstart file, 500 internal server error is returned. 


Additional info: Host is able to fetch the kickstart and continue provisioning.

Comment 6 Lukas Zapletal 2018-05-11 10:22:00 UTC
I can confirm. The workaround is to fix templates and use host_param() instead params[] - see the patch in comment 4.

Comment 8 Ivan Necas 2018-05-14 10:19:09 UTC

*** This bug has been marked as a duplicate of bug 1572980 ***


Note You need to log in before you can comment on or make changes to this bug.