Bug 1573355 - "gnome-shell --version" command is reporting wrong version of gnome-shell
Summary: "gnome-shell --version" command is reporting wrong version of gnome-shell
Keywords:
Status: CLOSED DUPLICATE of bug 1511454
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: gnome-shell
Version: 7.5
Hardware: All
OS: Linux
low
low
Target Milestone: rc
: ---
Assignee: Florian Müllner
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 02:02 UTC by amit yadav
Modified: 2019-06-11 21:44 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-06-11 21:44:42 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Knowledge Base (Article) 3428811 0 None None None 2018-05-01 02:15:13 UTC

Description amit yadav 2018-05-01 02:02:53 UTC
Description of problem:
Gnome-shell was rebased to version 3.26.2-5 in RHEL7.5. That can be confirmed from the rpm version and rpm changelog:

 # rpm -q gnome-shell
 gnome-shell-3.26.2-5.el7.x86_64

 # rpm -q  --changelog gnome-shell|less
 <snip>
 * Fri Nov 03 2017 Kalev Lember <klember@redhat.com> - 3.26.2-1
 - Update to 3.26.2
 - Related: #1481381
 </snip>

But "gnome-shell --version" is reporting wrong version:

 # gnome-shell --version
 GNOME Shell 3.25.4

Version-Release number of selected component (if applicable):
gnome-shell-3.26.2-5.el7.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run "gnome-shell --version" command on RHEL7.5 system.

Actual results:
Command report GNOME Shell version 3.25.4

Expected results:
Command should report actual version of gnome-shell

Additional info:

Comment 2 Tomas Pelka 2018-05-01 18:29:19 UTC
I believe dup of https://bugzilla.redhat.com/show_bug.cgi?id=1511454

Comment 3 Florian Müllner 2018-09-03 15:05:50 UTC
gnome-shell switch build systems to meson, which we didn't support prior to RHEL 7.6. So we included a downstream patch to add back autotools support, but we(*) forgot to update the version in the patch to the actual tarball version.

It's an easy fix for 7.5.z if we want it, other versions are unaffected.

(*) me probably, didn't check

Comment 4 amit yadav 2018-09-14 09:36:17 UTC
(In reply to Florian Müllner from comment #3)
> gnome-shell switch build systems to meson, which we didn't support prior to
> RHEL 7.6. So we included a downstream patch to add back autotools support,
> but we(*) forgot to update the version in the patch to the actual tarball
> version.
> 
> It's an easy fix for 7.5.z if we want it, other versions are unaffected.
> 
> (*) me probably, didn't check

If it's an easy fix, can we include in RHEL7.5.z?

Comment 5 Martin Krajnak 2018-09-14 09:47:44 UTC
just want to add that this was known issue from very early stages in RHEL-7.5 but we haven't been able to fix it back then, there is also problem with wrong version displayed in control-center

https://bugzilla.redhat.com/show_bug.cgi?id=1511454

Comment 6 Chris Williams 2019-06-11 21:44:42 UTC

*** This bug has been marked as a duplicate of bug 1511454 ***


Note You need to log in before you can comment on or make changes to this bug.