Bug 157338 - "On Member:" hostname doesn't show up on GULM cluster
"On Member:" hostname doesn't show up on GULM cluster
Status: CLOSED NEXTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: redhat-config-cluster (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jim Parsons
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2005-05-10 14:35 EDT by Corey Marthaler
Modified: 2009-04-16 16:08 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-20 16:12:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2005-05-10 14:35:59 EDT
Description of problem:
With a dlm cluster, the "On Member:" field in the MGMT tab shows the hostname of
the machine which the GUI is currently running on. This doens't work on a GULM
cluster, it just has a value of "False", which even that isn't true because the
node is actually a member of the cluster.

Version-Release number of selected component (if applicable):
-51
Comment 1 Jim Parsons 2005-05-17 09:38:26 EDT
There does not seem to be a way of getting current node info from the gulm_tool
like there is from cman_tool, so when on a GuLM style cluster, this field is
hidden. I am calling this a 'fix' because the On Member: field will no longer
display with garbage.

Of course, getHostName could be called, but I think it could be confusing if the
hostname was not the name given to the node in cluster.conf. If this is the
case, then it is an easy fix to add this, but I am reluctant to do so without
consideration from the group to confirm that this approach is correct.
Comment 2 Corey Marthaler 2005-05-20 16:12:08 EDT
calling this fixed then.

Note You need to log in before you can comment on or make changes to this bug.