Bug 1573401 - Dependency missing
Summary: Dependency missing
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: variety
Version: 28
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: MartinKG
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 04:48 UTC by Niels Kobschätzki
Modified: 2018-05-11 01:49 UTC (History)
1 user (show)

Fixed In Version: variety-0.6.8-2.fc28 variety-0.6.8-2.fc26 variety-0.6.8-2.fc27
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-09 21:24:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Niels Kobschätzki 2018-05-01 04:48:03 UTC
Description of problem:
The package is not installable because a dependency is missing.
Error output from "dnf install variety":
Error: 
 Problem: package variety-0.6.7-2.fc28.noarch requires pywebkitgtk, but none of the providers can be installed
  - conflicting requests
  - nothing provides libjavascriptcoregtk-1.0.so.0()(64bit) needed by pywebkitgtk-1.1.8-13.fc26.x86_64


Version-Release number of selected component (if applicable):
0.6.7-2.fc28


How reproducible:
Try to install the package


Steps to Reproduce:
1. dnf install variety

Actual results:
Error: 
 Problem: package variety-0.6.7-2.fc28.noarch requires pywebkitgtk, but none of the providers can be installed
  - conflicting requests
  - nothing provides libjavascriptcoregtk-1.0.so.0()(64bit) needed by pywebkitgtk-1.1.8-13.fc26.x86_64


Expected results:
No dependency errors and the package gets installed

Additional info:

Comment 1 Niels Kobschätzki 2018-05-01 05:14:28 UTC
I just installed variety from source https://github.com/varietywalls/variety and it seems that 0.6.8 doesn't need pywebkitgtk anymore. From what I've found pywebkitgtk should be retired anyways because it depends on webkit1 which shouldn't be in Fedora anymore.

The only extra I needed was this https://launchpad.net/python-distutils-extra to install it.

Comment 2 Fedora Update System 2018-05-01 09:49:18 UTC
variety-0.6.8-2.fc27 has been submitted as an update to Fedora 27. https://bodhi.fedoraproject.org/updates/FEDORA-2018-57d59f2222

Comment 3 Fedora Update System 2018-05-01 09:49:25 UTC
variety-0.6.8-2.fc26 has been submitted as an update to Fedora 26. https://bodhi.fedoraproject.org/updates/FEDORA-2018-01a32ee53c

Comment 4 Fedora Update System 2018-05-01 09:49:29 UTC
variety-0.6.8-2.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-9d7e3ec2e9

Comment 5 Fedora Update System 2018-05-01 10:58:10 UTC
variety-0.6.8-2.fc26 has been pushed to the Fedora 26 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-01a32ee53c

Comment 6 Fedora Update System 2018-05-01 11:59:41 UTC
variety-0.6.8-2.fc27 has been pushed to the Fedora 27 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-57d59f2222

Comment 7 Fedora Update System 2018-05-01 14:13:41 UTC
variety-0.6.8-2.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-9d7e3ec2e9

Comment 8 Fedora Update System 2018-05-09 21:24:03 UTC
variety-0.6.8-2.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2018-05-10 19:10:17 UTC
variety-0.6.8-2.fc26 has been pushed to the Fedora 26 stable repository. If problems still persist, please make note of it in this bug report.

Comment 10 Fedora Update System 2018-05-11 01:49:48 UTC
variety-0.6.8-2.fc27 has been pushed to the Fedora 27 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.