Bug 1573410 - install fails during - wait for the host to come up
Summary: install fails during - wait for the host to come up
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.2.19
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: ---
Assignee: Ido Rosenzwig
QA Contact: meital avital
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 06:43 UTC by Veaceslav Mindru
Modified: 2018-05-13 07:19 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-13 07:19:47 UTC
oVirt Team: Integration


Attachments (Terms of Use)

Description Veaceslav Mindru 2018-05-01 06:43:22 UTC
Description of problem:

hosted-engine --deploy fails during "wait for the host to come up" TASK

Version-Release number of selected component (if applicable):

[root@srv-1215 qemu]# rpm -qa | grep hosted                                                                                                                                                                        
ovirt-hosted-engine-setup-2.2.16-1.el7.centos.noarch                                                                                                                                                               
ovirt-hosted-engine-ha-2.2.10-1.el7.centos.noarch                                                                                                                                                                  
[root@srv-1215 qemu]# rpm -qa | grep ovirt-release                                                                                                                                                                 
ovirt-release42-4.2.2-3.el7.centos.noarch                                                                                                                                                                          
[root@srv-1215 qemu]#   
[root@srv-1215 qemu]# cat /etc/redhat-release                                                                                                                                                                      
CentOS Linux release 7.4.1708 (Core)                                                                                                                                                                               
[root@srv-1215 qemu]#   

How reproducible:

attempt a fresh install of hosted-engine both from CLI or from cockpit.


Steps to Reproduce:
1. install ovirt release
2. follow instructions https://www.ovirt.org/documentation/self-hosted/chap-Deploying_Self-Hosted_Engine/ 
3. hosted-engine --deploy or the same from cockpit 

Actual results:

observe

[ INFO  ] TASK [Set VLAN ID at datacenter level]                                                          
[ INFO  ] skipping: [localhost]                                                                           
[ INFO  ] TASK [Force host-deploy in offline mode]                                                        
[ INFO  ] ok: [localhost]                                                                                 
[ INFO  ] TASK [Add host]                                                                                 
[ INFO  ] changed: [localhost]                                                                            
[ INFO  ] TASK [Wait for the host to be up]                                                               
                                                                                                 
gg[ ERROR ] AuthError: Error during SSO authentication access_denied : Cannot authenticate user 'None@N/A': No valid profile found in credentials..
[ ERROR ] fatal: [localhost]: FAILED! => {"attempts": 120, "changed": false, "msg": "Error during SSO authentication access_denied : Cannot authenticate user 'None@N/A': No valid profile found in credentials.."}
[ INFO  ] TASK [include_tasks]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Remove local vm dir]
[ INFO  ] changed: [localhost]
[ INFO  ] TASK [Notify the user about a failure]
[ ERROR ] fatal: [localhost]: FAILED! => {"changed": false, "msg": "The system may not be provisioned according to the playbook results: please check the logs for the issue, fix accordingly or re-deploy from scra
tch.\n"}
[ ERROR ] [DEPRECATION WARNING]: Using tests as filters is deprecated. Instead of using

[ ERROR ] `result|succeeded` instead use `result is succeeded`. This feature will be

[ ERROR ] removed in version 2.9. Deprecation warnings can be disabled by setting

[ ERROR ] deprecation_warnings=False in ansible.cfg.

[ ERROR ] [DEPRECATION WARNING]: Using tests as filters is deprecated. Instead of using

[ ERROR ] `result|succeeded` instead use `result is succeeded`. This feature will be

[ ERROR ] removed in version 2.9. Deprecation warnings can be disabled by setting

[ ERROR ] deprecation_warnings=False in ansible.cfg.

[ ERROR ] Failed to execute stage 'Closing up': Failed executing ansible-playbook
[ INFO  ] Stage: Clean up
[ INFO  ] Cleaning temporary resources
[ INFO  ] TASK [Gathering Facts]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [include_tasks]
[ INFO  ] ok: [localhost]
[ INFO  ] TASK [Remove local vm dir]
[ INFO  ] ok: [localhost]
[ INFO  ] Generating answer file '/var/lib/ovirt-hosted-engine-setup/answers/answers-20180501020751.conf'
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Hosted Engine deployment failed: please check the logs for the issue, fix accordingly or re-deploy from scratch.
          Log file is located at /var/log/ovirt-hosted-engine-setup/ovirt-hosted-engine-setup-20180501014949-38qw1q.log
You have new mail in /var/spool/mail/root


also if query the API  you can see hosts up 0/0

    <product_info>
        <name>oVirt Engine</name>
        <version>
            <build>2</build>
            <full_version>4.2.2.6-1.el7.centos</full_version>
            <major>4</major>
            <minor>2</minor>
            <revision>0</revision>
        </version>
    </product_info>
    <special_objects>
        <blank_template href="/ovirt-engine/api/templates/00000000-0000-0000-0000-000000000000" id="00000000-0000-0000-0000-000000000000"/>
        <root_tag href="/ovirt-engine/api/tags/00000000-0000-0000-0000-000000000000" id="00000000-0000-0000-0000-000000000000"/>
    </special_objects>
    <summary>
        <hosts>
            <active>0</active>
            <total>0</total>
        </hosts>
        <storage_domains>
            <active>0</active>
            <total>1</total>
        </storage_domains>
        <users>
            <active>1</active>
            <total>1</total>
        </users>
        <vms>
            <active>0</active>
            <total>0</total>
        </vms>
    </summary>
    <time>2018-05-01T05:59:16.969Z</time>
    <authenticated_user href="/ovirt-engine/api/users/4dbee730-4d04-11e8-a1c0-00163e372d3c" id="4dbee730-4d04-11e8-a1c0-00163e372d3c"/>
    <effective_user href="/ovirt-engine/api/users/4dbee730-4d04-11e8-a1c0-00163e372d3c" id="4dbee730-4d04-11e8-a1c0-00163e372d3c"/>



Expected results:

installation works 


Additional info:

i tried to manually reproduce add the host, simulate same as per  
https://github.com/oVirt/ovirt-hosted-engine-setup/blob/master/src/ansible/bootstrap_local_vm.yml#L288

---                                                                                                                                                                                                                
- hosts: srv-1214.dom.net
  vars:
    HOST_NAME: "srv-1215.dom.net"
    HOST_ADDRESS: "srv-1215.dom.net"
    ovirt_auth:
      url: "https://srv-1214.dom.net/ovirt-engine/api"
      username: "admin@internal"
      password: "pass"
      insecure: True

  tasks:
  - name: Add host
    ovirt_hosts:
      name: "{{ HOST_NAME }}"
      state: present
      password: "pass"
      address: "{{ HOST_ADDRESS }}"
      auth: "{{ ovirt_auth }}"


obviously the hosted-engine VM get's shut down during vdsm/libvirt reconfigure

Comment 1 Veaceslav Mindru 2018-05-01 08:36:48 UTC
tested with latest 2.2.19 same results ...

Comment 2 Simone Tiraboschi 2018-05-02 07:26:22 UTC
This:
 [ ERROR ] fatal: [localhost]: FAILED! => {"attempts": 120, "changed": false, "msg": "Error during SSO authentication access_denied : Cannot authenticate user 'None@N/A': No valid profile found in credentials.."}

looks pretty strange.

Can you please attach deployment logs?

Comment 3 Simone Tiraboschi 2018-05-02 08:21:04 UTC
Can you please also report which version of ovirt-engine-appliance you were using?

Comment 4 Nikolai Sednev 2018-05-02 08:35:32 UTC
Works for me on these components:
ovirt-engine-4.2.3.3-0.1.el7.noarch
rhvm-appliance-4.2-20180427.0.el7.noarch
ovirt-hosted-engine-setup-2.2.19-1.el7ev.noarch
ovirt-hosted-engine-ha-2.2.11-1.el7ev.noarch
Linux 3.10.0-862.el7.x86_64 #1 SMP Wed Mar 21 18:14:51 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 (Maipo)

Tested as CLI deployments of Node 0 and vintage flow on all types of storages (Gluster, iSCSI, MS Windows 2016 iSCSI target server, NFS) except for FC due to https://bugzilla.redhat.com/show_bug.cgi?id=1571467.

I suspect that this issue happens on old appliance.

Comment 5 Ido Rosenzwig 2018-05-13 07:19:47 UTC
Closing the bug since it work for Nikolai and the reporter didn't answer for more then a week.


Note You need to log in before you can comment on or make changes to this bug.