Bug 1573461 - [RFE] Sort Hosted-Engine answerfile's lines
Summary: [RFE] Sort Hosted-Engine answerfile's lines
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-hosted-engine-setup
Classification: oVirt
Component: General
Version: 2.2.19
Hardware: Unspecified
OS: Unspecified
low
low
Target Milestone: ovirt-4.2.5
: 2.2.23
Assignee: Ido Rosenzwig
QA Contact: Nikolai Sednev
URL:
Whiteboard:
Depends On:
Blocks: ovirt-hosted-engine-setup-2.2.24
TreeView+ depends on / blocked
 
Reported: 2018-05-01 10:42 UTC by Ido Rosenzwig
Modified: 2018-07-31 15:26 UTC (History)
5 users (show)

Fixed In Version: ovirt-hosted-engine-setup-2.2.23-1.el7ev
Doc Type: No Doc Update
Doc Text:
undefined
Clone Of:
Environment:
Last Closed: 2018-07-31 15:26:52 UTC
oVirt Team: Integration
rule-engine: ovirt-4.2+
ylavi: planning_ack+
rule-engine: devel_ack+
mavital: testing_ack+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 90796 0 master MERGED src: plugins: Sort generated answerfile's lines 2020-06-08 11:00:06 UTC
oVirt gerrit 92013 0 ovirt-hosted-engine-setup-2.2 MERGED src: plugins: Sort generated answerfile's lines 2020-06-08 11:00:06 UTC

Description Ido Rosenzwig 2018-05-01 10:42:32 UTC
Description of problem:

The lines in the answerfile should be sorted to make it easy for the user to search and edit keys

How reproducible:
100%


Steps to Reproduce:
1. Run hosted-engine --deploy (with any answers)
2. The content of generated answerfile is not sorted
3.

Actual results:
keys aren't sorted. looks like this:

...
OVEHOSTED_STORAGE/iSCSIPortalIPAddress=none:None
OVEHOSTED_STORAGE/metadataVolumeUUID=str:b4b875f9-f8a2-4552-91d8-7b21cccb4e26
OVEHOSTED_STORAGE/sdUUID=str:4d03ddeb-9740-402f-88f4-5c4adc057459
OVEHOSTED_STORAGE/iSCSITargetName=none:None
OVEHOSTED_STORAGE/metadataImageUUID=str:39953286-6686-4b1b-8ff0-80a1996efb85
OVEHOSTED_STORAGE/lockspaceVolumeUUID=str:5a5c88e0-8705-4628-b7d3-f4e8386e8b77
OVEHOSTED_STORAGE/iSCSIPortalPort=none:None
OVEHOSTED_STORAGE/imgUUID=str:7edb3d30-0ae0-4273-b5c7-96567708a20b
OVEHOSTED_STORAGE/confImageUUID=str:99f1062c-056c-4347-8b7e-207b39eb96d1
OVEHOSTED_STORAGE/spUUID=str:00000000-0000-0000-0000-000000000000
OVEHOSTED_STORAGE/lockspaceImageUUID=str:ae6f42e9-5941-4fb6-8e60-a2dfc0a6065f
OVEHOSTED_ENGINE/enableHcGlusterService=none:None
OVEHOSTED_STORAGE/storageDomainName=str:hosted_storage
OVEHOSTED_STORAGE/iSCSIPortal=none:None
...

Expected results:
keys are sorted. should look like this:

...
OVEHOSTED_STORAGE/LunID=none:None
OVEHOSTED_STORAGE/domainType=none:None
OVEHOSTED_STORAGE/iSCSIDiscoverUser=none:None
OVEHOSTED_STORAGE/iSCSIPortal=none:None
OVEHOSTED_STORAGE/iSCSIPortalIPAddress=none:None
OVEHOSTED_STORAGE/iSCSIPortalPort=none:None
OVEHOSTED_STORAGE/iSCSIPortalUser=none:None
OVEHOSTED_STORAGE/iSCSITargetName=none:None
OVEHOSTED_STORAGE/imgSizeGB=none:None
OVEHOSTED_STORAGE/imgUUID=str:0b284801-4134-49f4-8f6b-003e8c10defb
OVEHOSTED_STORAGE/lockspaceImageUUID=none:None
OVEHOSTED_STORAGE/lockspaceVolumeUUID=none:None
OVEHOSTED_STORAGE/metadataImageUUID=none:None
OVEHOSTED_STORAGE/metadataVolumeUUID=none:None
OVEHOSTED_STORAGE/mntOptions=none:None
OVEHOSTED_STORAGE/nfsVersion=none:None
OVEHOSTED_STORAGE/storageDomainConnection=none:None
OVEHOSTED_STORAGE/storageDomainName=str:hosted_storage
OVEHOSTED_STORAGE/volUUID=str:c7b157c8-662f-4fce-897f-060f10edfd14
...

Comment 1 Nikolai Sednev 2018-07-08 14:22:10 UTC
Looks something like this now:
alma04 ~]# cat /var/lib/ovirt-hosted-engine-setup/answers/answers-20180708151106.conf
[environment:default]
OVEHOSTED_CORE/deployProceed=bool:True
OVEHOSTED_CORE/rollbackProceed=none:None
OVEHOSTED_CORE/screenProceed=none:None
OVEHOSTED_CORE/upgradeProceed=none:None
OVEHOSTED_ENGINE/clusterName=str:Default
OVEHOSTED_ENGINE/enableHcGlusterService=none:None
OVEHOSTED_ENGINE/insecureSSL=none:None
OVEHOSTED_NETWORK/bridgeName=str:ovirtmgmt
OVEHOSTED_NETWORK/fqdn=str:nsednev-he-1.qa.lab.tlv.redhat.com
OVEHOSTED_NETWORK/gateway=str:10.35.95.254
OVEHOSTED_NOTIF/destEmail=str:root@localhost
OVEHOSTED_NOTIF/smtpPort=str:25
OVEHOSTED_NOTIF/smtpServer=str:localhost
OVEHOSTED_NOTIF/sourceEmail=str:root@localhost
OVEHOSTED_STORAGE/LunID=str:3514f0c5a51601879
OVEHOSTED_STORAGE/discardSupport=bool:False
OVEHOSTED_STORAGE/domainType=str:iscsi
OVEHOSTED_STORAGE/iSCSIDiscoverUser=none:None
OVEHOSTED_STORAGE/iSCSIPortal=str:1
OVEHOSTED_STORAGE/iSCSIPortalIPAddress=str:10.35.146.225
OVEHOSTED_STORAGE/iSCSIPortalPort=str:3260
OVEHOSTED_STORAGE/iSCSIPortalUser=str:
OVEHOSTED_STORAGE/iSCSITargetName=str:iqn.2008-05.com.xtremio:xio00153500071-514f0c50023f6c05
OVEHOSTED_STORAGE/imgSizeGB=str:58
OVEHOSTED_STORAGE/imgUUID=str:e27ddc4b-1f3c-48a1-8601-2c3c46140fb5
OVEHOSTED_STORAGE/lockspaceImageUUID=none:None
OVEHOSTED_STORAGE/lockspaceVolumeUUID=none:None
OVEHOSTED_STORAGE/metadataImageUUID=none:None
OVEHOSTED_STORAGE/metadataVolumeUUID=none:None
OVEHOSTED_STORAGE/mntOptions=none:None
OVEHOSTED_STORAGE/nfsVersion=none:None
OVEHOSTED_STORAGE/storageDomainConnection=str:10.35.146.225
OVEHOSTED_STORAGE/storageDomainName=str:hosted_storage
OVEHOSTED_STORAGE/volUUID=str:26f7a3ff-7a0b-4525-881e-39b659ad9239
OVEHOSTED_VM/automateVMShutdown=bool:True
OVEHOSTED_VM/cdromUUID=str:232dfc54-4b15-4bc4-a0ac-a7de8fbdb908
OVEHOSTED_VM/cloudInitISO=str:generate
OVEHOSTED_VM/cloudinitExecuteEngineSetup=bool:True
OVEHOSTED_VM/cloudinitInstanceDomainName=str:qa.lab.tlv.redhat.com
OVEHOSTED_VM/cloudinitInstanceHostName=str:nsednev-he-1.qa.lab.tlv.redhat.com
OVEHOSTED_VM/cloudinitVMDNS=bool:False
OVEHOSTED_VM/cloudinitVMETCHOSTS=bool:False
OVEHOSTED_VM/cloudinitVMStaticCIDR=bool:False
OVEHOSTED_VM/cloudinitVMTZ=str:Asia/Jerusalem
OVEHOSTED_VM/consoleUUID=str:9716b4bd-8c7a-4710-8cd1-5e5086f8f1a4
OVEHOSTED_VM/emulatedMachine=str:pc-i440fx-rhel7.3.0
OVEHOSTED_VM/nicUUID=str:83bb44f1-2c5b-40b5-b93d-13564e94c0f8
OVEHOSTED_VM/ovfArchive=str:
OVEHOSTED_VM/rootSshAccess=str:yes
OVEHOSTED_VM/rootSshPubkey=str:
OVEHOSTED_VM/vmCDRom=none:None
OVEHOSTED_VM/vmMACAddr=str:00:16:3e:31:3c:31
OVEHOSTED_VM/vmMemSizeMB=int:16384
OVEHOSTED_VM/vmVCpus=str:4

Works for me on these components:
ovirt-hosted-engine-ha-2.2.15-1.el7ev.noarch
ovirt-hosted-engine-setup-2.2.23-1.el7ev.noarch
rhvm-appliance-4.2-20180620.0.el7.noarch
Linux 3.10.0-862.6.3.el7.x86_64 #1 SMP Fri Jun 15 17:57:37 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux
Red Hat Enterprise Linux Server release 7.5 (Maipo)

Moving to verified.

Comment 2 Sandro Bonazzola 2018-07-31 15:26:52 UTC
This bugzilla is included in oVirt 4.2.5 release, published on July 30th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.5 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.