Bug 1573488 - infra: comment-on-issue can't handle anything except ASCII
Summary: infra: comment-on-issue can't handle anything except ASCII
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: project-infrastructure
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: bugs@gluster.org
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 13:45 UTC by Kaleb KEITHLEY
Modified: 2018-05-03 15:23 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-03 15:23:31 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Kaleb KEITHLEY 2018-05-01 13:45:47 UTC
Description of problem:

नमस्ते see https://build.gluster.org/job/comment-on-issue/6514/console

test failed because submitter has a 'ü' in his name in the Signed-off by: line. After I changed it to "ue" then the test passed.

This is 2018 and iso-8859-1, iso-8859-15, and utf-8 have been around for decades. But we're using a tool (UnicodeDecode.py or something) that despite its Unicode name somehow only wants to recognize ASCII (from 1963) characters.

Most of the rest of gerrit seems to be perfectly happy with the ü in his name AFAICT.


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:


Note You need to log in before you can comment on or make changes to this bug.