Bug 1573512 - [v2v] When moving VMware VMs to be under a cluster, it seems CFME\v2v is not fully updated with the change.
Summary: [v2v] When moving VMware VMs to be under a cluster, it seems CFME\v2v is not ...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Providers
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: cfme-future
Assignee: Martin Perina
QA Contact: Yadnyawalk Tale
URL:
Whiteboard: v2v,vmware refresh
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 15:02 UTC by Ilanit Stein
Modified: 2019-04-24 13:12 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-07-29 09:58:16 UTC
Category: Bug
Cloudforms Team: RHEVM
Target Upstream Version:


Attachments (Terms of Use)
evm_log.tgz (1.12 MB, application/x-gzip)
2018-05-01 15:02 UTC, Ilanit Stein
no flags Details
automation_log.tgz (116.67 KB, application/x-gzip)
2018-05-01 15:03 UTC, Ilanit Stein
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Bugzilla 1573467 0 medium CLOSED [v2v] Transform a single VM from VMware to RHV fail with unclear error message, when VM is not under a cluster. 2021-02-22 00:41:40 UTC

Internal Links: 1573467

Description Ilanit Stein 2018-05-01 15:02:03 UTC
Description of problem:
Due to Bug 1573467 - [v2v] Transform a single VM from VMware to RHV fail with unclear error message, when VM is not under a cluster,

A cluster change was done in the VMware setup:
VMs were under a host, and the host was moved to be under a cluster.

This is in order to overcome bug 1573467, and have v2v working.

On CFME side, the VMware VMs indeed were displayed associated with the cluster,
however the v2v still failed.

Remove & add the VMware setup resolved the problem: v2v worked OK.

 
Version-Release number of selected component (if applicable):
CFME-5.8.4.2/vSphere 6.5

Comment 2 Ilanit Stein 2018-05-01 15:02:42 UTC
Created attachment 1429213 [details]
evm_log.tgz

Comment 3 Ilanit Stein 2018-05-01 15:03:15 UTC
Created attachment 1429214 [details]
automation_log.tgz

Comment 4 Adam Grare 2018-05-02 16:12:52 UTC
Ilanit can you be a little more specific about what fails?

I just tried this and after moving the host into a cluster I can:
1. See the host under the cluster in the MIQ UI
2. See the host under the cluster in the rails console
   ems.ems_clusters.first.hosts
3. See the cluster from the host in the rails console
   host.find_by(:name => "hostname").ems_cluster
4. See the cluster from a VM on that host
   host.find_by(:name => "hostname").vms.first.ems_cluster

As far as I can tell everything looks correct.

Comment 5 Ilanit Stein 2018-05-03 04:44:07 UTC
Adam,

Thanks for investigating,
Based on your comment, it seems that after moving the VMs to be under a cluster in VMware, CFME Core gets updated with the change.

I tested VM transform of a single VM from VMware to RHV, and it failed due to bug  1573467 (It assumed cluster should always exist). I then moved the VMs to be under cluster on VMware, however the VM transform still failed.
In CFME UI, it indeed seem that the cluster change was reflected.
As VM transform still fail, it might be that the VM transform part, didn't adapt to the cluster change.

Moving bug to the RHV team.

Comment 7 Ilanit Stein 2018-05-24 06:46:52 UTC
VM transformation for single VM migration in CloudForms

Comment 8 Moran Goldboim 2018-07-29 09:58:16 UTC
This function is deprecated in favor of the new Infrastructure Migration Solution.


Note You need to log in before you can comment on or make changes to this bug.