Bug 1573519 - [RFE] MIQLDAP to SSSD - miqldap_to_sssd conversion script should verify admin creds.
Summary: [RFE] MIQLDAP to SSSD - miqldap_to_sssd conversion script should verify admin...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: Appliance
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: GA
: cfme-future
Assignee: Gregg Tanzillo
QA Contact: Mike Shriver
URL:
Whiteboard: auth:miqldap:externalauth
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 15:17 UTC by Matt Pusateri
Modified: 2019-07-24 18:39 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2019-07-24 18:39:43 UTC
Category: ---
Cloudforms Team: ---
Target Upstream Version:


Attachments (Terms of Use)

Description Matt Pusateri 2018-05-01 15:17:43 UTC
Description of problem:
  Right now it completes and puts bad creds in sssd.conf.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. Configure MIQLDAP
2. Run miqldap_to_sssd conversion script specifying incorrect domain admin password.


Actual results:
Incorrect password is stored in /etc/sssd.conf, so logins fail.

Expected results:
Credentials should be validated before script converts and fail with error message.

Additional info:
https://bugzilla.redhat.com/show_bug.cgi?id=1573509
 https://bugzilla.redhat.com/show_bug.cgi?id=1573511

Comment 2 Joe Vlcek 2019-07-24 18:39:43 UTC
I'm going to close this as wontfix because this is an obscure edge case.

Please reopen with justification if needed.


Note You need to log in before you can comment on or make changes to this bug.