Bug 1573538 - Cannot install Fedora 28 on !x86 architectures
Summary: Cannot install Fedora 28 on !x86 architectures
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Anaconda Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: ARMTracker ZedoraTracker TRACKER-bugs-affecting-libguestfs PPCTracker
TreeView+ depends on / blocked
 
Reported: 2018-05-01 16:02 UTC by Richard W.M. Jones
Modified: 2019-04-30 15:53 UTC (History)
13 users (show)

(edit)
Clone Of:
(edit)
Last Closed: 2019-04-30 15:53:44 UTC


Attachments (Terms of Use)
fedora-28-ppc64le.ks (1.12 KB, text/plain)
2018-05-01 16:02 UTC, Richard W.M. Jones
no flags Details
anaconda.log (4.92 KB, text/plain)
2018-05-01 16:03 UTC, Richard W.M. Jones
no flags Details
dbus.log (3.52 KB, text/plain)
2018-05-01 16:03 UTC, Richard W.M. Jones
no flags Details
program.log (274 bytes, text/plain)
2018-05-01 16:03 UTC, Richard W.M. Jones
no flags Details
syslog (338.65 KB, text/plain)
2018-05-01 16:05 UTC, Richard W.M. Jones
no flags Details
ttys (3.66 KB, text/plain)
2018-05-02 16:24 UTC, Richard W.M. Jones
no flags Details
f27-syslog (473.48 KB, text/plain)
2018-05-02 16:57 UTC, Richard W.M. Jones
no flags Details

Description Richard W.M. Jones 2018-05-01 16:02:06 UTC
Description of problem:

When trying to builder virt-builder images of Fedora 28, I found a
problem installing on every !x86 architecture (ppc64, ppc64le,
aarch64, armv7l).  It works on x86-64 and i686.

The visible error is:

Starting installer, one moment...

** (process:1642): WARNING **: 15:03:27.870: Cannot load the LVM plugin        
anaconda 28.22.10-1.fc28 for Fedora 28 started.                                
 * installation log files are stored in /tmp during the installation           
 * shell is available on TTY2
 * if the graphical installation interface fails to start, try again with the  
   inst.text bootoption to start text installation                             
 * when reporting a bug add logs from /tmp as separate text/plain attachments  
15:11:22 Anaconda DBus modules failed to start on time.                        
15:11:22 Anaconda DBus modules failed to start on time.                        

...

Pane is dead

I also captured the logs which are attached (for ppc64le, but
I assume the failures are the same on all architectures).

Version-Release number of selected component (if applicable):

Fedora 28

How reproducible:

100%

Steps to Reproduce:

fedora-28-ppc64le.ks is attached.

virt-install \
    --transient \
    --ram=4096 \
    --arch=ppc64le \
    --machine=pseries \
    --cpu=power8 \
    --vcpus=1 \
    --os-variant=fedora26 \
    --initrd-inject=fedora-28-ppc64le.ks \
    --extra-args=ks=file:/fedora-28-ppc64le.ks proxy=http://cache.home.annexia.org:3128 console=tty0 console=hvc0 rd_NO_PLYMOUTH \
    --disk=disk.img,size=6,format=raw \
    --location=https://dl.fedoraproject.org/pub/fedora-secondary/releases/28/Server/ppc64le/os/ \
    --serial=pty \
    --nographics

Comment 1 Richard W.M. Jones 2018-05-01 16:02 UTC
Created attachment 1429297 [details]
fedora-28-ppc64le.ks

Comment 2 Richard W.M. Jones 2018-05-01 16:03 UTC
Created attachment 1429298 [details]
anaconda.log

Comment 3 Richard W.M. Jones 2018-05-01 16:03 UTC
Created attachment 1429299 [details]
dbus.log

Comment 4 Richard W.M. Jones 2018-05-01 16:03 UTC
Created attachment 1429300 [details]
program.log

Comment 5 Richard W.M. Jones 2018-05-01 16:05 UTC
Created attachment 1429301 [details]
syslog

Comment 6 Richard W.M. Jones 2018-05-01 16:06:16 UTC
Those are all the logs I have.  The other log files are all empty:

total 364
-rw-r--r--. 1 rjones rjones   5040 May  1 16:54 anaconda.log
-rw-r--r--. 1 rjones rjones   3603 May  1 16:54 dbus.log
-rw-r--r--. 1 rjones rjones      0 May  1 16:54 ifcfg.log
-rw-r--r--. 1 rjones rjones      0 May  1 16:54 packaging.log
-rw-r--r--. 1 rjones rjones    274 May  1 16:54 program.log
drwxr-xr-x. 2 rjones rjones   4096 May  1 16:54 pymp-f0xw1goh
-rw-r--r--. 1 rjones rjones      0 May  1 16:54 sensitive-info.log
-rw-r--r--. 1 rjones rjones      0 May  1 16:54 storage.log
-rw-------. 1 rjones rjones 346776 May  1 16:54 syslog
drwxr-xr-x. 2 rjones rjones   4096 May  1 16:54 tmux-0

Comment 7 Martin Kolman 2018-05-02 15:46:16 UTC
I'm wondering if this might be related to bug 1569045, where apparently on some PPC64LE machines /sys/class/tty/console/active is an empty string. This can cause code that makes use of it to find the "real" hardware console by iterating from the top-level "console" alias to break down. And we do have such code in the Anaconda systemd service generator:

https://github.com/rhinstaller/anaconda/blob/master/data/systemd/anaconda-generator#L26

So could you check the content /sys/class/tty/console/active of ? And ideally any other console entry in /sys/class/tty/ that has the active property.

Also output from:

ls /sys/class/tty/* 

Would be useful.

There is also a second possibility - that this has been happening already in the past, but there was no timeout in <F28, so Anaconda just took really long to start but managed to start in the end. So could you try the same thing with F27 and attach the syslog output ? That would help us see if anaconda-shell console also used to restart over and over or if it's a new behavior.

And thanks in advance for all the logs! :)

Comment 8 Richard W.M. Jones 2018-05-02 16:23:40 UTC
# cat /sys/class/tty/console/active
tty0 hvc0

Comment 9 Richard W.M. Jones 2018-05-02 16:24 UTC
Created attachment 1430187 [details]
ttys

Output of ls /sys/class/tty/*

Comment 10 Richard W.M. Jones 2018-05-02 16:57 UTC
Created attachment 1430224 [details]
f27-syslog

syslog from Fedora 27 install

Comment 11 James Szinger 2018-05-02 22:00:11 UTC
I'm seeing this on my armhfp virt-install, but not with aarch64, on the same x86 host.  I suspect the difference might be the speed of the VMs.  The armhpf VM gets to 'Welcome to Fedora' in about 400 seconds, but aarch64 take only about 40 seconds.  The f28 syslog in comment 5 show it takes 16 minutes to boot, so it's no speed daemon:

15:44:25,741 INFO systemd:Startup finished in 58.030s (kernel) + 10min 27.912s (initrd) + 4min 51.581s (userspace) = 16min 17.524s.

My successful aarch64 virt-install get to that line in only 8 minutes.

I think the timeouts might not be long enough for the slow virtualized CPUs.

Comment 12 Adam Williamson 2018-05-09 01:37:16 UTC
"I think the timeouts might not be long enough for the slow virtualized CPUs."

Yeah, this seems pretty plausible to me. Non-accelerated virt is *extremely* slow.

Comment 13 Peter Robinson 2018-05-09 06:52:32 UTC
Also potentially add in rhbz 1572944 for the RTC/random issue as a possibility to make things worse/slower too.

Comment 14 Vendula Poncova 2018-05-16 12:59:12 UTC
Fixed in a pull request: https://github.com/rhinstaller/anaconda/pull/1467

Comment 15 Tom Herbert 2018-06-18 21:46:43 UTC
I suspect that timeout mod was a fig leaf. I got a little further trying to install F29 on emulated Aarch64 but not much further,

An unknown error has occured, look at the /tmp/anaconda-tb* file(s) for more details


===============================================================================
b'An unknown error has occurred'
===============================================================================
anaconda 29.17 exception report
Traceback (most recent call first):
  File "/usr/lib64/python3.6/site-packages/gi/overrides/BlockDev.py", line 869, in wrapped
    raise transform[1](msg)
  File "/usr/lib/python3.6/site-packages/blivet/formats/lvmpv.py", line 125, in _create
    blockdev.lvm.pvcreate(self.device, data_alignment=self.data_alignment)
  File "/usr/lib/python3.6/site-packages/blivet/threads.py", line 53, in run_with_lock
    return m(*args, **kwargs)
  File "/usr/lib/python3.6/site-packages/blivet/formats/__init__.py", line 513, in create

ne 438, in run_task
    self._task(*self._task_args, **self._task_kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 472, in start
    self.run_task()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation_tasks.py", line 304, in start
    item.start()
  File "/usr/lib64/python3.6/site-packages/pyanaconda/installation.py", line 372, in doInstall
    installation_queue.start()
  File "/usr/lib64/python3.6/threading.py", line 864, in run
    self._target(*self._args, **self._kwargs)
  File "/usr/lib64/python3.6/site-packages/pyanaconda/threading.py", line 286, in run
    threading.Thread.run(self)
gi.overrides.BlockDev.LVMError: Failed to call the 'PvCreate' method on the '/com/redhat/lvmdbus1/Manager' object: Timeout was reached


The dbus log:
The dbus log has:
dbus-daemon[1484]: Failed to activate service 'org.fedoraproject.Anaconda.Modules.Storage': timed out (service_start_timeout=120000ms)

Ihave not as yet successfully installed either F29 or F28 on emulated Aarch64 on Qemu.

Comment 16 Vendula Poncova 2018-06-19 09:13:22 UTC
Hi Tom, your bug is a duplicate of #1586148. It is not related to this bug.


Note You need to log in before you can comment on or make changes to this bug.