Bug 1573556 - GIMP 2.10 flatpak doesn't launch after install, cannot be removed again (remove button does nothing)
Summary: GIMP 2.10 flatpak doesn't launch after install, cannot be removed again (remo...
Keywords:
Status: CLOSED EOL
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-software
Version: 27
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Richard Hughes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 16:57 UTC by ell1e
Modified: 2018-11-30 21:21 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-30 21:21:20 UTC
Type: Bug


Attachments (Terms of Use)

Description ell1e 2018-05-01 16:57:37 UTC
Description of problem:
GIMP 2.10 flatpak doesn't launch after install (there was some error about "localhost" not being available, sorry I don't have the exact wording - I can't get it to reappear), and it cannot be removed again (remove button does nothing). Now it's stuck in a state where it will neither launch nor uninstall.

Version-Release number of selected component (if applicable):
3.28.1

How reproducible:
no idea, on my other machine it worked fine. but on my desktop I'm now in this broken state

Steps to Reproduce:
1. Install https://flathub.org/apps/details/org.gimp.GIMP with GNOME software
2. Attempt to launch
3. Attempt to remove after failed launch

Actual results:
can't launch, can't remove

Expected results:
can launch, can remove

Additional info:

Comment 1 ell1e 2018-05-01 17:02:30 UTC
Ok, I checked: GIMP didn't show up in flatpak list, even though GNOME Software insisted it was installed (but wouldn't let me remove or launch it).

After running flatpak install ./org.gimp.GIMP.flatpakref manually on the command line, everything works now. However, at some point GNOME software was for sure seriously confused about whatever state about it being installed / not installed it had caused :-/

Comment 2 Ben Cotton 2018-11-27 15:56:20 UTC
This message is a reminder that Fedora 27 is nearing its end of life.
On 2018-Nov-30  Fedora will stop maintaining and issuing updates for
Fedora 27. It is Fedora's policy to close all bug reports from releases
that are no longer maintained. At that time this bug will be closed as
EOL if it remains open with a Fedora  'version' of '27'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version.

Thank you for reporting this issue and we are sorry that we were not 
able to fix it before Fedora 27 is end of life. If you would still like 
to see this bug fixed and are able to reproduce it against a later version 
of Fedora, you are encouraged  change the 'version' to a later Fedora 
version prior this bug is closed as described in the policy above.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.

Comment 3 Ben Cotton 2018-11-30 21:21:20 UTC
Fedora 27 changed to end-of-life (EOL) status on 2018-11-30. Fedora 27 is
no longer maintained, which means that it will not receive any further
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen this bug against that version. If you
are unable to reopen this bug, please file a new report against the
current release. If you experience problems, please add a comment to this
bug.

Thank you for reporting this bug and we are sorry it could not be fixed.


Note You need to log in before you can comment on or make changes to this bug.