Bug 1573604 - scaleup playbook fails at approve bootstrap nodes step [NEEDINFO]
Summary: scaleup playbook fails at approve bootstrap nodes step
Keywords:
Status: CLOSED DUPLICATE of bug 1579676
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.10.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: 3.10.0
Assignee: Michael Gugino
QA Contact: Johnny Liu
URL:
Whiteboard: aos-scalability-310
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 18:48 UTC by Jeremy Eder
Modified: 2018-05-30 13:51 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-30 13:51:39 UTC
Target Upstream Version:
mgugino: needinfo? (jeder)


Attachments (Terms of Use)

Comment 5 Michael Gugino 2018-05-18 14:31:01 UTC
It looks like master was added to oo_nodes_to_bootstrap even though it shouldn't be.

We'll need to adjust the grouping for scaleup play of nodes.

Also, looks like no CSR was generated on the new node for some reason.

Investigating.

Comment 6 Michael Gugino 2018-05-18 16:17:48 UTC
Scaleup appears to be working as intended for me.

There is possibly a race condition between starting node and approving CSR.

Jeremy, can you confirm that after the scaleup playbook fails that there is a node CSR pending with 'oc get csr'

This would require the auto-approver to be off (or, if it's on, you should be able to see a completed CSR eventually for the new node).

Comment 7 Scott Dodson 2018-05-24 13:14:32 UTC
Going to add a 30 second pause between the time we start the node and when we first attmept to approve the CSRs. Long term we need to review oc_adm_csr and ensure that it's properly looping for CSRs but we'll do that as followup.

Comment 9 Scott Dodson 2018-05-30 13:51:39 UTC
API and ETCD are going away and/or not fully available before we continue with the upgrade. Duping this with bug 1579676

*** This bug has been marked as a duplicate of bug 1579676 ***


Note You need to log in before you can comment on or make changes to this bug.