Bug 1573621 - SELinux is preventing 72733A6D61696E20513A526567 from using the 'dac_override' capabilities.
Summary: SELinux is preventing 72733A6D61696E20513A526567 from using the 'dac_override...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:9e8b1d0182f10b77661d3b5dd58...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 19:34 UTC by Tomas Toth
Modified: 2018-07-25 20:09 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-23 12:00:39 UTC
Type: ---


Attachments (Terms of Use)

Description Tomas Toth 2018-05-01 19:34:04 UTC
Description of problem:
SELinux is preventing 72733A6D61696E20513A526567 from using the 'dac_override' capabilities.

*****  Plugin dac_override (91.4 confidence) suggests   **********************

If you want to help identify if domain needs this access or you have a file with the wrong permissions on your system
Then turn on full auditing to get path information about the offending file and generate the error again.
Do

Turn on full auditing
# auditctl -w /etc/shadow -p w
Try to recreate AVC. Then execute
# ausearch -m avc -ts recent
If you see PATH record check ownership/permissions on file, and fix it,
otherwise report as a bugzilla.

*****  Plugin catchall (9.59 confidence) suggests   **************************

If you believe that 72733A6D61696E20513A526567 should have the dac_override capability by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c '72733A6D61696E20513A526567' --raw | audit2allow -M my-72733A6D61696E20513A526567
# semodule -X 300 -i my-72733A6D61696E20513A526567.pp

Additional Information:
Source Context                system_u:system_r:syslogd_t:s0
Target Context                system_u:system_r:syslogd_t:s0
Target Objects                Unknown [ capability ]
Source                        72733A6D61696E20513A526567
Source Path                   72733A6D61696E20513A526567
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.1-21.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.16.5-300.fc28.x86_64 #1 SMP Fri
                              Apr 27 17:38:36 UTC 2018 x86_64 x86_64
Alert Count                   28
First Seen                    2018-04-28 22:43:16 CEST
Last Seen                     2018-05-01 21:30:36 CEST
Local ID                      4c739d45-c465-45bc-a89f-6954f23df9eb

Raw Audit Messages
type=AVC msg=audit(1525203036.640:266): avc:  denied  { dac_override } for  pid=847 comm=72733A6D61696E20513A526567 capability=1  scontext=system_u:system_r:syslogd_t:s0 tcontext=system_u:system_r:syslogd_t:s0 tclass=capability permissive=0


Hash: 72733A6D61696E20513A526567,syslogd_t,syslogd_t,capability,dac_override

Version-Release number of selected component:
selinux-policy-3.14.1-21.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.5-300.fc28.x86_64
type:           libreport

Comment 3 Steve 2018-05-06 12:39:26 UTC
I have the exact same issue, 1195 times 72 hours.

Comment 5 Steve 2018-05-23 11:59:38 UTC
I solved my problem. 
It was rsyslogd. Which was replaced by journal a long time ago.
Removed package and problem solved.
This machine has not had a clean install for many, many years. Always updated and for some reason syslog was never removed during the update process.

Comment 6 Lukas Vrabec 2018-05-23 12:00:39 UTC
Thanks Steve.

Comment 7 Akarshan Biswas 2018-06-20 18:26:52 UTC
Description of problem:
Always reproducible when waking the system from sleep.

Version-Release number of selected component:
selinux-policy-3.14.1-32.fc28.noarch

Additional info:
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.16-300.fc28.x86_64
type:           libreport


Note You need to log in before you can comment on or make changes to this bug.