Bug 1573625 - [upstream][v2v] Migration Details Page Should Auto-Refresh
Summary: [upstream][v2v] Migration Details Page Should Auto-Refresh
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat CloudForms Management Engine
Classification: Red Hat
Component: UI - OPS
Version: 5.9.0
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: GA
: 5.10.0
Assignee: Brett Thurber
QA Contact: Kedar Kulkarni
URL:
Whiteboard: v2v
Depends On:
Blocks: 1588577
TreeView+ depends on / blocked
 
Reported: 2018-05-01 19:47 UTC by Kedar Kulkarni
Modified: 2019-02-11 14:01 UTC (History)
10 users (show)

Fixed In Version: 5.10.0.0
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1588577 (view as bug list)
Environment:
Last Closed: 2019-02-11 14:01:41 UTC
Category: ---
Cloudforms Team: CFME Core
Target Upstream Version:


Attachments (Terms of Use)
Screenshot (121.16 KB, image/gif)
2018-05-17 21:09 UTC, Kedar Kulkarni
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Github https://github.com/ManageIQ miq_v2v_ui_plugin issues 311 0 None None None 2018-05-22 13:57:57 UTC

Description Kedar Kulkarni 2018-05-01 19:47:21 UTC
Description of problem:
Migration details page should auto refresh. Page is shown in screenshot attached. It does not refresh automatically, but the spinners give false impression that it may auto-refresh.

Version-Release number of selected component (if applicable):
master.20180430231107_6437e92

How reproducible:
100%

Steps to Reproduce:
1.Create Infra Mapping
2.Create Migration plan and execute it
3.Click on plan being executed, which will show you migration plan details page

Actual results:
Information on page such as timer, description and progress bars do not refresh dynamically. need to refresh page manually.

Expected results:
Page should refresh dynamically.

Additional info:

Comment 2 Sudhir Mallamprabhakara 2018-05-15 18:47:56 UTC
Can you verify against the new build?

Comment 3 Kedar Kulkarni 2018-05-16 00:11:12 UTC
Sudhir, 

This has not been fixed yet. Here is a GitHub issue for that:

https://github.com/priley86/miq_v2v_ui_plugin/issues/311

-KK.

Comment 5 Kedar Kulkarni 2018-05-17 21:09:28 UTC
Created attachment 1438126 [details]
Screenshot

Comment 6 Serena 2018-05-18 02:02:36 UTC
@KK can you explain what your expectations are in this case?

This is a failed migration plan.  There is one VM in the plan, and the migration of that VM has already failed.  Since that's the case, the utilization bar will never change.

Comment 7 Kedar Kulkarni 2018-05-18 12:40:53 UTC
@Serena,
I agree that this is a failed migration. But if you navigate to same screen while migration is in progress, the utilization bar does not update dynamically.You need to hit refresh manually to see progress in the bar, as well as the clock for elapsed time increase. This all should update without needing to hit refresh on the page. 
Hope that helps.

Comment 15 Kedar Kulkarni 2018-07-02 20:54:16 UTC
on 5.10.0.2 Migration request details page does auto-refresh


Note You need to log in before you can comment on or make changes to this bug.