Bug 1573636 - nisserver-plugin.so has unresolved symbol due to F28 moved to libnsl without linking to it
Summary: nisserver-plugin.so has unresolved symbol due to F28 moved to libnsl without ...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: slapi-nis
Version: 28
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
Assignee: Alexander Bokovoy
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-01 20:09 UTC by John Obaterspok
Modified: 2018-05-16 13:06 UTC (History)
4 users (show)

Fixed In Version: slapi-nis-0.56.2-6.fc28
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-16 13:06:59 UTC
Type: Bug


Attachments (Terms of Use)

Description John Obaterspok 2018-05-01 20:09:06 UTC
Description of problem:
ldd -r /usr/lib64/dirsrv/plugins/nisserver-plugin.so

undefined symbol: xdr_ypresp_master	(/usr/lib64/dirsrv/plugins/nisserver-plugin.so)
undefined symbol: xdr_ypreq_key	(/usr/lib64/dirsrv/plugins/nisserver-plugin.so)
undefined symbol: xdr_ypresp_key_val	(/usr/lib64/dirsrv/plugins/nisserver-plugin.so)
undefined symbol: xdr_ypresp_maplist	(/usr/lib64/dirsrv/plugins/nisserver-plugin.so)
undefined symbol: xdr_ypreq_nokey	(/usr/lib64/dirsrv/plugins/nisserver-plugin.so)
undefined symbol: xdr_ypresp_order	(/usr/lib64/dirsrv/plugins/nisserver-plugin.so)
undefined symbol: xdr_ypresp_all	(/usr/lib64/dirsrv/plugins/nisserver-plugin.so)
undefined symbol: xdr_ypresp_val	(/usr/lib64/dirsrv/plugins/nisserver-plugin.so)
undefined symbol: slapi_ch_malloc	(/usr/lib64/dirsrv/plugins/nisserver-plugin.so)

nsslapd: report_error - Netscape Portable Runtime error -5977: /usr/lib64/dirsrv/plugins/nisserver-plugin.so: undefined symbol: xdr_ypresp_master

Because of this the freeipa server fails to start.

Comment 1 Alexander Bokovoy 2018-05-07 14:31:45 UTC
Fixed in the package git and package is built in koji. I'm planning to do a combined freeipa+slapi-nis release.

Comment 2 Kenny Root 2018-05-08 00:33:47 UTC
I can confirm that https://kojipkgs.fedoraproject.org//packages/slapi-nis/0.56.2/6.fc28/x86_64/slapi-nis-0.56.2-6.fc28.x86_64.rpm fixes the error for me.

Comment 3 Fedora Update System 2018-05-08 06:12:33 UTC
slapi-nis-0.56.2-6.fc28 freeipa-4.6.90.pre1-7.fc28 has been submitted as an update to Fedora 28. https://bodhi.fedoraproject.org/updates/FEDORA-2018-a22497315b

Comment 4 Fedora Update System 2018-05-10 01:28:54 UTC
freeipa-4.6.90.pre1-7.fc28, slapi-nis-0.56.2-6.fc28 has been pushed to the Fedora 28 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2018-a22497315b

Comment 5 Fedora Update System 2018-05-16 13:06:59 UTC
freeipa-4.6.90.pre1-7.fc28, slapi-nis-0.56.2-6.fc28 has been pushed to the Fedora 28 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.