Bug 1573696 - Failed to uninstall eventrouter.
Summary: Failed to uninstall eventrouter.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Logging
Version: 3.10.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.10.0
Assignee: ewolinet
QA Contact: Qiaoling Tang
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 03:35 UTC by Qiaoling Tang
Modified: 2018-07-30 19:15 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: No Doc Update
Doc Text:
As part of fixing our check that we are only installing logging in a single namespace we didn't update to not include the eventrouter in the list of namespaces we installed into which created a false positive.
Clone Of:
Environment:
Last Closed: 2018-07-30 19:14:34 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2018:1816 None None None 2018-07-30 19:15:04 UTC

Description Qiaoling Tang 2018-05-02 03:35:42 UTC
Description of problem:

Failed to uninstall eventrouter with logging. The messages are in the below:

fatal: [$master]: FAILED! => {
    "assertion": "_current_logging_namespace.split(\" \") | count <= 1", 
    "changed": false, 
    "evaluated_to": false, 
    "failed": true, 
    "msg": "Configuring aggregated logging in multiple namespaces is not supported:   current namespace(s): default openshift-logging   specified namespace: default openshift-logging"
}


Version-Release number of selected component (if applicable):
# oc version
oc v3.10.0-0.30.0
kubernetes v1.10.0+b81c8f8
features: Basic-Auth GSSAPI Kerberos SPNEGO

openshift v3.10.0-0.31.0
kubernetes v1.10.0+b81c8f8

# rpm -qa | grep openshift-ansible
openshift-ansible-3.10.0-0.31.0.git.0.9f771c7.el7.noarch
openshift-ansible-roles-3.10.0-0.31.0.git.0.9f771c7.el7.noarch
openshift-ansible-docs-3.10.0-0.31.0.git.0.9f771c7.el7.noarch
openshift-ansible-playbooks-3.10.0-0.31.0.git.0.9f771c7.el7.noarch

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.5 (Maipo)
# uname -a
Linux host-$master-ip 3.10.0-862.el7.x86_64 #1 SMP Wed Mar 21 18:14:51 EDT 2018 x86_64 x86_64 x86_64 GNU/Linux


How reproducible:
Always

Steps to Reproduce:
1. Deploy eventrouter by setting the following value in inventory file and run ansible-playbooks:
openshift_logging_install_logging=true
openshift_logging_install_eventrouter=true

2. Wait until all pods are running, then set "openshift_logging_install_logging=false
openshift_logging_install_eventrouter=false" in inventory and rerun ansible-playbooks

Actual results:
Failed to uninstall eventrouter

Expected results:
Eventrouter can be uninstalled successfully.

Additional info:
image version
logging-curator/images/v3.10.0-0.31.0.0
logging-fluentd/images/v3.10.0-0.31.0.0
logging-eventrouter/images/v3.10.0-0.31.0.0

Comment 3 Qiaoling Tang 2018-05-07 10:02:39 UTC
verified on openshift v3.10.0-0.33.0.0

Comment 5 errata-xmlrpc 2018-07-30 19:14:34 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2018:1816


Note You need to log in before you can comment on or make changes to this bug.