Bug 1573702 - OCP prerequisite playbook fails while trying to get current installed docker version
Summary: OCP prerequisite playbook fails while trying to get current installed docker ...
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: OpenShift Container Platform
Classification: Red Hat
Component: Installer
Version: 3.9.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.9.z
Assignee: Scott Dodson
QA Contact: Johnny Liu
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 05:31 UTC by Ashmitha Ambastha
Modified: 2018-11-19 21:23 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-11-19 21:23:33 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description Ashmitha Ambastha 2018-05-02 05:31:09 UTC
Description of problem:
-----------------------
OCP prerequisite playbook fails while trying to get current installed docker version. I was trying to set up OCP using advanced installer on RHEL 7.5 VMs. The prerequisite.yml fails with unable to get current installed docker version even though docker is installed on all the nodes (master and the worker nodes).

NOTE- They are all fresh RHEL 7.5 VMs.

Version-Release number of selected component (if applicable): 
-----------------------
# rpm -qa | grep docker
docker-1.13.1-58.git87f2fab.el7.x86_64
docker-rhel-push-plugin-1.13.1-58.git87f2fab.el7.x86_64
docker-client-1.13.1-58.git87f2fab.el7.x86_64
atomic-openshift-docker-excluder-3.9.25-1.git.0.6bc473e.el7.noarch
docker-common-1.13.1-58.git87f2fab.el7.x86_64

How reproducible: 
-----------------------
Reproducible in every attempt.


Steps to Reproduce:
-----------------------

1. Created 4 RHEL 7.5 VMs.

2. Subscribed to Live pool and executed commands from step 3 to step 12

3. #subscription-manager repos     --enable="rhel-7-server-rpms"     --enable="rhel-7-server-extras-rpms"     --enable="rhel-7-server-ose-3.9-rpms"     --enable="rhel-7-fast-datapath-rpms"     --enable="rhel-7-server-ansible-2.4-rpms"

4. #yum install wget git net-tools bind-utils iptables-services bridge-utils bash-completion kexec-tools sos psacct 

5. #yum update 

6. #yum install atomic-openshift-utils 

7. #yum install docker-1.13.1

8. #rpm -V docker-1.13.1

9. #cat <<EOF > /etc/sysconfig/docker-storage-setup
   DEVS=/dev/sdb
   VG=docker-vg
   EOF

10. docker-storage-setup

11. Created an ansible inventory file called inventory.sample

12. #ansible-playbook -i inventory.sample  /usr/share/ansible/openshift-ansible/playbooks/prerequisites.yml

Actual results: 
-----------------------

The playbook is failing with the following error message:
TASK [container_runtime : Get current installed Docker version] *************************************************************************************************************
FAILED - RETRYING: Get current installed Docker version (4 retries left).
FAILED - RETRYING: Get current installed Docker version (4 retries left).
FAILED - RETRYING: Get current installed Docker version (4 retries left).
FAILED - RETRYING: Get current installed Docker version (4 retries left).
FAILED - RETRYING: Get current installed Docker version (3 retries left).
FAILED - RETRYING: Get current installed Docker version (3 retries left).
FAILED - RETRYING: Get current installed Docker version (3 retries left).
FAILED - RETRYING: Get current installed Docker version (3 retries left).
FAILED - RETRYING: Get current installed Docker version (2 retries left).
FAILED - RETRYING: Get current installed Docker version (2 retries left).
FAILED - RETRYING: Get current installed Docker version (2 retries left).
FAILED - RETRYING: Get current installed Docker version (2 retries left).
FAILED - RETRYING: Get current installed Docker version (1 retries left).
FAILED - RETRYING: Get current installed Docker version (1 retries left).
FAILED - RETRYING: Get current installed Docker version (1 retries left).
FAILED - RETRYING: Get current installed Docker version (1 retries left).
fatal: [dhcp46-4.lab.eng.blr.redhat.com]: FAILED! => {"attempts": 4, "changed": false, "cmd": "repoquery --plugins --installed --qf '%{version}' docker", "failed": true, "msg": "[Errno 8] Exec format error", "rc": 8}
fatal: [dhcp47-32.lab.eng.blr.redhat.com]: FAILED! => {"attempts": 4, "changed": false, "cmd": "repoquery --plugins --installed --qf '%{version}' docker", "failed": true, "msg": "[Errno 8] Exec format error", "rc": 8}
fatal: [dhcp46-65.lab.eng.blr.redhat.com]: FAILED! => {"attempts": 4, "changed": false, "cmd": "repoquery --plugins --installed --qf '%{version}' docker", "failed": true, "msg": "[Errno 8] Exec format error", "rc": 8}
fatal: [dhcp47-51.lab.eng.blr.redhat.com]: FAILED! => {"attempts": 4, "changed": false, "cmd": "repoquery --plugins --installed --qf '%{version}' docker", "failed": true, "msg": "[Errno 8] Exec format error", "rc": 8}
	to retry, use: --limit @/usr/share/ansible/openshift-ansible/playbooks/prerequisites.retry


Expected results:

Since docker is already installed. This task should not fail the prerequisite playbook. 

Additional info:
Logs will be attached if required.

# rpm -qa | grep yum-utils 
yum-utils-1.1.31-45.el7.noarch

Comment 1 Scott Dodson 2018-05-04 13:50:06 UTC
What happens when you run `repoquery --plugins --installed --qf '%{version}' docker` on the host?

Comment 3 Russell Teague 2018-11-19 21:23:33 UTC
There appear to be no active cases related to this bug. As such we're closing this bug in order to focus on bugs that are still tied to active customer cases. Please re-open this bug if you feel it was closed in error or a new active case is attached.


Note You need to log in before you can comment on or make changes to this bug.