Bug 1573709 - SELinux is preventing kdm from 'create' accesses on the file kdewallet.salt.
Summary: SELinux is preventing kdm from 'create' accesses on the file kdewallet.salt.
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: selinux-policy
Version: 28
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Lukas Vrabec
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:c0c10c92bb64bc8c8a66c192b36...
: 1573708 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 06:00 UTC by Alexander Kurtakov
Modified: 2018-05-02 11:43 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 11:43:52 UTC
Type: ---


Attachments (Terms of Use)

Description Alexander Kurtakov 2018-05-02 06:00:41 UTC
Description of problem:
SELinux is preventing kdm from 'create' accesses on the file kdewallet.salt.

*****  Plugin catchall (100. confidence) suggests   **************************

If you believe that kdm should be allowed create access on the kdewallet.salt file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# ausearch -c 'kdm' --raw | audit2allow -M my-kdm
# semodule -X 300 -i my-kdm.pp

Additional Information:
Source Context                system_u:system_r:xdm_t:s0-s0:c0.c1023
Target Context                system_u:object_r:httpd_user_content_t:s0
Target Objects                kdewallet.salt [ file ]
Source                        kdm
Source Path                   kdm
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.14.1-24.fc28.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.16.5-300.fc28.x86_64 #1 SMP Fri
                              Apr 27 17:38:36 UTC 2018 x86_64 x86_64
Alert Count                   11
First Seen                    2018-03-30 20:00:50 EEST
Last Seen                     2018-05-02 08:49:00 EEST
Local ID                      a91a31c4-7f71-4311-873b-d4f9df6961fa

Raw Audit Messages
type=AVC msg=audit(1525240140.374:416): avc:  denied  { create } for  pid=5625 comm="kdm" name="kdewallet.salt" scontext=system_u:system_r:xdm_t:s0-s0:c0.c1023 tcontext=system_u:object_r:httpd_user_content_t:s0 tclass=file permissive=0


Hash: kdm,xdm_t,httpd_user_content_t,file,create

Version-Release number of selected component:
selinux-policy-3.14.1-24.fc28.noarch

Additional info:
component:      selinux-policy
reporter:       libreport-2.9.5
hashmarkername: setroubleshoot
kernel:         4.16.5-300.fc28.x86_64
type:           libreport

Comment 1 Lukas Vrabec 2018-05-02 11:28:39 UTC
*** Bug 1573708 has been marked as a duplicate of this bug. ***

Comment 2 Lukas Vrabec 2018-05-02 11:43:52 UTC
Hi Alexander, 

I believe your system is mislabeled. Could you please run:
# restorecon -Rv / 

To fix labels on your system. 

Thanks,
Lukas.


Note You need to log in before you can comment on or make changes to this bug.