Bug 1573731 - login loop after updating from Fedora 27 to Fedora 28
Summary: login loop after updating from Fedora 27 to Fedora 28
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-shell
Version: 28
Hardware: x86_64
OS: Linux
unspecified
urgent
Target Milestone: ---
Assignee: Owen Taylor
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 07:30 UTC by dchatterjee172
Modified: 2018-05-04 21:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 08:39:30 UTC
Type: Bug


Attachments (Terms of Use)
journalctl (44.93 KB, text/plain)
2018-05-02 07:30 UTC, dchatterjee172
no flags Details

Description dchatterjee172 2018-05-02 07:30:16 UTC
Created attachment 1429737 [details]
journalctl

Description of problem: After updating from Fedora 27 to to 28 when I tried to login, I am facing a login loop. After giving correct password, again login screen is coming. I checked journalctl and saw that gnome-shell is crashing. I have attached a log also. I have tried both wayland and xorg, the result is same.

Comment 1 dchatterjee172 2018-05-02 08:39:30 UTC
fixed 
apparently it was because of an extension.

Comment 2 Paul Finnigan 2018-05-04 21:38:16 UTC
I too suffered this problem. I could however login with the command line.

I removed all my extensions by moving all the extension directories from

~/.local/share/gnome-shell/extension

to a safe placer then I could log on. 

Perhaps the upgrade should check for extensions that are added from the Gnome Shell Extensions web site and disable them. This would stop people who are not that familiar with gnome 3 like me from suffering if this does happen.

I know it sounds like hand holding, it is. But some of us need it. 

Closing this off as NOTABUG is wrong. The upgrade process has failed. 

IT IS A BUG in the upgrade process not in gnome-shell.


Note You need to log in before you can comment on or make changes to this bug.