Bugzilla (bugzilla.redhat.com) will be under maintenance for infrastructure upgrades and will not be available on July 31st between 12:30 AM - 05:30 AM UTC. We appreciate your understanding and patience. You can follow status.redhat.com for details.
Bug 1573739 - On CFME, VM html5 Spice console becomes blurry, once stating to write in it.
Summary: On CFME, VM html5 Spice console becomes blurry, once stating to write in it.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: spice
Version: 7.7
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: rc
: ---
Assignee: Default Assignee for SPICE Bugs
QA Contact: Ilanit Stein
URL:
Whiteboard:
: 1589269 (view as bug list)
Depends On:
Blocks: 1672533
TreeView+ depends on / blocked
 
Reported: 2018-05-02 07:50 UTC by Ilanit Stein
Modified: 2019-08-06 12:48 UTC (History)
6 users (show)

Fixed In Version: spice-0.14.0-7.el7
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
: 1672533 (view as bug list)
Environment:
Last Closed: 2019-08-06 12:47:53 UTC
Target Upstream Version:


Attachments (Terms of Use)
RHV_VM_console_spice.png (14.20 KB, image/png)
2018-05-02 07:57 UTC, Ilanit Stein
no flags Details


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2019:2106 0 None None None 2019-08-06 12:48:00 UTC

Description Ilanit Stein 2018-05-02 07:50:49 UTC
Description of problem:
On CFME, connected to a RHV provider:
When opening a VM console, for VM display type is Spice, it is connecting (opening a browser tab, as expected, and connects to the console),
however once staring to write in the console, the screen begin to be blurry
(See screenshot).

Version-Release number of selected component (if applicable):
CFME-5.9.2.3
RHV-4.2.2.5

Version of the Host, where VM runs:
OS Version:RHEL - 7.5 - 8.el7
OS Description:Employee SKU
Kernel Version:3.10.0 - 862.el7.x86_64
KVM Version:2.10.0 - 21.el7_5.1
LIBVIRT Version:libvirt-3.9.0-14.el7_5.2
VDSM Version:vdsm-4.20.23-1.el7ev
SPICE Version:0.14.0 - 2.el7 

How reproducible:
100%

Comment 2 Ilanit Stein 2018-05-02 07:57:33 UTC
Created attachment 1429747 [details]
RHV_VM_console_spice.png

Comment 3 Brian McLaughlin 2018-06-27 13:30:19 UTC
*** Bug 1589269 has been marked as a duplicate of this bug. ***

Comment 4 Christophe Fergeau 2018-12-17 11:02:37 UTC
This seems similar to a bug which was fixed by https://gitlab.freedesktop.org/spice/spice/commit/48179332d9da0
If this patch does not help, some extra coordination will be needed in order to find resources to investigate this, as spice-html5 is not supported by the spice team.

Comment 7 Christophe Fergeau 2018-12-18 16:00:25 UTC
If you cannot test it, I'd add this patch to the rhel7 regardless as this fixes a regression

Comment 8 Christophe Fergeau 2018-12-21 10:09:38 UTC
Setting this to POST, though some test results would be useful ;)

Comment 9 Ilanit Stein 2018-12-23 12:08:10 UTC
Thanks Christophe for providing this fix.
I'd like to test it, and I am trying to figure out how I should apply it:
The host on which the VM runs, is RHEL-7.6, and has spice-server-0.14.0-6.el7.x86_64.

Is this Spice version include the mentioned fix, and I can test it, using CFME?
If no, what are the steps, that need to be taken please, to implement the fix?

Comment 10 Uri Lublin 2018-12-23 13:09:32 UTC
The patch in comment #4 is not included in spice-server-0.14.0-6.el7.x86_64

Comment 15 Ilanit Stein 2019-06-20 10:56:58 UTC
Verified.

Checked a RHEL-7.4 VM spice console. VM is running on a RHEL-7.7-7.el7 host.
This is for RHV-4.3.5-0.1.el7, connected to CFME-5.10.6.0 

I managed to open the console, type commands,and it worked just fine.

Comment 17 errata-xmlrpc 2019-08-06 12:47:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2019:2106


Note You need to log in before you can comment on or make changes to this bug.