Bug 1573767 - OSP12 deployment with Ceph failed with resources.WorkflowTasks_Step2_Execution: ERROR.
Summary: OSP12 deployment with Ceph failed with resources.WorkflowTasks_Step2_Executio...
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: rhosp-director
Version: 12.0 (Pike)
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: ---
Assignee: RHOS Maint
QA Contact: Amit Ugol
URL:
Whiteboard:
: 1624249 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 08:40 UTC by Chen
Modified: 2019-11-21 21:08 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-23 12:10:38 UTC
Target Upstream Version:


Attachments (Terms of Use)
template files that the customer was using (4.42 KB, application/x-gzip)
2018-05-02 08:46 UTC, Chen
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 3434011 None None None 2018-05-07 15:23:47 UTC

Description Chen 2018-05-02 08:40:33 UTC
Description of problem:

OSP12 deployment with Ceph failed with resources.WorkflowTasks_Step2_Execution: ERROR.

2018-04-30 08:19:51Z [overcloud.AllNodesDeploySteps.WorkflowTasks_Step2_Execution]: CREATE_FAILED  resources.WorkflowTasks_Step2_Execution: ERROR
2018-04-30 08:19:52Z [overcloud.AllNodesDeploySteps]: CREATE_FAILED  Resource CREATE failed: resources.WorkflowTasks_Step2_Execution: ERROR
2018-04-30 08:19:53Z [overcloud.AllNodesDeploySteps]: CREATE_FAILED  resources.AllNodesDeploySteps: Resource CREATE failed: resources.WorkflowTasks_Step2_Execution: ERROR
2018-04-30 08:19:53Z [overcloud]: CREATE_FAILED  Resource CREATE failed: resources.AllNodesDeploySteps: Resource CREATE failed: resources.WorkflowTasks_Step2_Execution: ERROR

 Stack overcloud CREATE_FAILED

overcloud.AllNodesDeploySteps.WorkflowTasks_Step2_Execution:
  resource_type: OS::Mistral::ExternalResource
  physical_resource_id: 5bd135a3-9528-4d69-90cb-e918685001d9
  status: CREATE_FAILED
  status_reason: |
    resources.WorkflowTasks_Step2_Execution: ERROR
Heat Stack create failed.
Heat Stack create failed.

Version-Release number of selected component (if applicable):

OSP12
openstack-tripleo-heat-templates-7.0.9-8.el7ost.noarch


How reproducible:

100% in customer site

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

The customer tried 1 ctrl + 2 compute without any problems. Then the overcloud is deleted and tried with 1 ctrl + 2 compute + 3 ceph and the problem occurred.

Comment 2 Chen 2018-05-02 08:46:09 UTC
Created attachment 1429797 [details]
template files that the customer was using

Comment 10 John Fulton 2018-05-23 12:10:38 UTC
My understanding is that the SizeLimitExceededException was reached because of the value set for CephAnsiblePlaybookVerbosity produced too much data and that lowering this value resolved the issue.

Comment 11 Alex Schultz 2019-11-21 21:08:35 UTC
*** Bug 1624249 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.