Bug 1573784 - Deprecation warning in fluentd forward plugin
Summary: Deprecation warning in fluentd forward plugin
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: ovirt-engine-metrics
Classification: oVirt
Component: Generic
Version: 1.1.4.2
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ovirt-4.2.4
: ---
Assignee: Shirly Radco
QA Contact: Lukas Svaty
URL:
Whiteboard:
Depends On:
Blocks: 1581842
TreeView+ depends on / blocked
 
Reported: 2018-05-02 09:29 UTC by Shirly Radco
Modified: 2018-06-26 08:42 UTC (History)
1 user (show)

Fixed In Version: ovirt-engine-metrics-1.1.5
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-26 08:42:59 UTC
oVirt Team: Metrics
rule-engine: ovirt-4.2+


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
oVirt gerrit 91122 0 master MERGED Update fluentd forward plugin settings 2020-02-20 21:52:35 UTC

Description Shirly Radco 2018-05-02 09:29:33 UTC
Description of problem:
The forward elasticsearch plugin host and port parameters are deprecated
and we need to update the fluentd config for it.

May  2 04:46:12 lago-rhv-suite-4-2-engine fluentd: 2018-05-02 04:46:12 -0400 [info]: adding match pattern="project.ovirt-metrics**" type="forward"
May  2 04:46:12 lago-rhv-suite-4-2-engine fluentd: 2018-05-02 04:46:12 -0400 [warn]: 'port' parameter is deprecated: User <server> host xxx </server> instead.
May  2 04:46:12 lago-rhv-suite-4-2-engine fluentd: 2018-05-02 04:46:12 -0400 [warn]: 'host' parameter is deprecated: Use <server> port xxx </server> instead.


Version-Release number of selected component (if applicable):
1.1.4.2

How reproducible:
100%

Steps to Reproduce:
1. Run oVirt metrics setup to configure collectd and fluentd
2. Check fluentd log file
3.

Actual results:
Warning messages

Expected results:
No warning messages

Additional info:

Comment 1 Shirly Radco 2018-05-08 08:33:28 UTC
The issue is with the fluentd secure forward plugin.

Comment 2 Shirly Radco 2018-05-10 08:28:24 UTC
The issue was with regular forward plugin. Not the secure forward.

Comment 3 Lukas Svaty 2018-06-11 07:26:43 UTC
verified in ovirt-engine-metrics-1.1.5.1-1.el7ev.noarch

Comment 4 Sandro Bonazzola 2018-06-26 08:42:59 UTC
This bugzilla is included in oVirt 4.2.4 release, published on June 26th 2018.

Since the problem described in this bug report should be
resolved in oVirt 4.2.4 release, it has been closed with a resolution of CURRENT RELEASE.

If the solution does not work for you, please open a new bug report.


Note You need to log in before you can comment on or make changes to this bug.