Bug 1573801 - Fedora 27 does not boot on Lenovo T400s since kernel
Summary: Fedora 27 does not boot on Lenovo T400s since kernel
Keywords:
Status: CLOSED DUPLICATE of bug 1572944
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 27
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 09:51 UTC by Eduard Vopicka
Modified: 2018-05-03 13:28 UTC (History)
17 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-03 13:28:49 UTC
Type: Bug


Attachments (Terms of Use)
dmesg from boot with kernel 4.16.3-200.fc27.x86_64 which works. Can't supply dmesg or anything from failed boots because of the problem manifests too early (74.02 KB, text/plain)
2018-05-02 09:51 UTC, Eduard Vopicka
no flags Details

Description Eduard Vopicka 2018-05-02 09:51:46 UTC
Created attachment 1429820 [details]
dmesg from boot with kernel 4.16.3-200.fc27.x86_64 which works. Can't supply dmesg or anything from failed boots because of the problem manifests too early

Description of problem: After power up, goes through boot menu, but never comes to passphrase entry for encrypted volume.


Version-Release number of selected component (if applicable): 4.16.5-200.fc27.x86_64, 4.16.4-200.fc27.x86_64


How reproducible: Always on my system, it is enough just to power up and watch the screen.


Steps to Reproduce:
1. Power on the notebook
2. Watch the screen, after going through boot menu it never comes to passphrase entry for encrypted volume

Actual results: Black screen


Expected results: Should boot normally like with kernel 4.16.3-200.fc27.x86_64


Additional info: My T440s has ATI graphics. The disk layout is de facto standard, sda1 - /boot, sda2 - PV with encryption and / and everything in LVM

Comment 1 Eduard Vopicka 2018-05-02 09:56:06 UTC
Errata: There is no ATI graphic on that T440s, it has Intel graphics.

Comment 2 Eduard Vopicka 2018-05-02 10:38:29 UTC
4.16.3-200.fc27.x86_64 from updates-testing exhibits the same problem

Please fix this soon, I would like to update one of T400s notebooks which is designate to receive early releases and updates to F28 as soon as possible, but I am worrying to do so while experiencing the described problem.

Comment 3 Eduard Vopicka 2018-05-02 11:53:01 UTC
Update: The hanged boot can be tricked to complete by pressing some strange key combinations or sequences, like <Alt><Alt><Enter> or <Ctrl>+<Alt>+<Enter>.

Not sure if there is any key sequence/combo always working on the first attempt. This works with 4.16.6-200.fc27.x86_64, 4.16.5-200.fc27.x86_64, not tested with uninstalled 4.16.4-200.fc27.x86_64.

I have also tried to enable the TPM module which i normally have in the visible, but not active state, e.g. may be said non-standard setting. Changing TPM to active in BIOS did not fix the problem.

Comment 4 Eduard Vopicka 2018-05-02 12:03:52 UTC
When in hanged state, reaction to <Ctrl>+<Alt>+<Del> is "reboot: Restarting system" followed by immediate reboot.

Comment 5 Jeremy Cline 2018-05-02 13:19:20 UTC
Hi Eduard,

This sounds like it may be https://bugzilla.redhat.com/show_bug.cgi?id=1572944. Can you try 4.16.6-202[0]? It's on its way to updates-testing, but you can download it from koji[1] as well. Thanks!

[0] https://bodhi.fedoraproject.org/updates/kernel-4.16.6-202.fc27
[1] https://koji.fedoraproject.org/koji/taskinfo?taskID=26711183

Comment 6 Eduard Vopicka 2018-05-03 01:20:29 UTC
Hi Jeremy,

thanks for pointing me in the 4.16.6-202 direction, this version does not exhibit the problem.

Thanks again,

Ed

Comment 7 Jeremy Cline 2018-05-03 13:28:49 UTC
Perfect, thanks for confirming!

*** This bug has been marked as a duplicate of bug 1572944 ***


Note You need to log in before you can comment on or make changes to this bug.