Bug 1573809 - rust-tokio-io: FTBFS in Fedora rawhide
Summary: rust-tokio-io: FTBFS in Fedora rawhide
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: rust-tokio-io
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL: http://apps.fedoraproject.org/koschei...
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 09:59 UTC by Igor Gnatenko
Modified: 2018-06-16 10:04 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-06-16 10:04:03 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Github tokio-rs tokio-io issues 105 None None None 2018-05-02 09:59:16 UTC

Description Igor Gnatenko 2018-05-02 09:59:16 UTC
Description of problem:
Package rust-tokio-io fails to build from source in Fedora rawhide.

Version-Release number of selected component (if applicable):
0.1.6-1.fc29

Steps to Reproduce:
koji build --scratch f29 rust-tokio-io-0.1.6-1.fc29.src.rpm

Additional info:
This package is tracked by Koschei. See:
http://apps.fedoraproject.org/koschei/package/rust-tokio-io

```
+ /usr/bin/cargo build --release -j6
   Compiling cfg-if v0.1.2
   Compiling libc v0.2.40
   Compiling futures v0.1.21
   Compiling byteorder v1.2.2
     Running `/usr/bin/rustc --crate-name cfg_if /usr/share/cargo/registry/cfg-if-0.1.2/src/lib.rs --crate-type lib --emit=dep-info,link -C opt-level=3 -C metadata=b0daed5ecce94f78 -C extra-filename=-b0daed5ecce94f78 --out-dir /builddir/build/BUILD/tokio-io-0.1.6/target/release/deps -L dependency=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps --cap-lints allow -Copt-level=3 -Cdebuginfo=2 -Clink-arg=-Wl,-z,relro,-z,now`
     Running `/usr/bin/rustc --crate-name libc /usr/share/cargo/registry/libc-0.2.40/src/lib.rs --crate-type lib --emit=dep-info,link -C opt-level=3 --cfg 'feature="default"' --cfg 'feature="use_std"' -C metadata=3f2bf739f781a931 -C extra-filename=-3f2bf739f781a931 --out-dir /builddir/build/BUILD/tokio-io-0.1.6/target/release/deps -L dependency=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps --cap-lints allow -Copt-level=3 -Cdebuginfo=2 -Clink-arg=-Wl,-z,relro,-z,now`
     Running `/usr/bin/rustc --crate-name futures /usr/share/cargo/registry/futures-0.1.21/src/lib.rs --crate-type lib --emit=dep-info,link -C opt-level=3 --cfg 'feature="default"' --cfg 'feature="use_std"' --cfg 'feature="with-deprecated"' -C metadata=83d86e5cd520b9a1 -C extra-filename=-83d86e5cd520b9a1 --out-dir /builddir/build/BUILD/tokio-io-0.1.6/target/release/deps -L dependency=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps --cap-lints allow -Copt-level=3 -Cdebuginfo=2 -Clink-arg=-Wl,-z,relro,-z,now`
     Running `/usr/bin/rustc --crate-name byteorder /usr/share/cargo/registry/byteorder-1.2.2/src/lib.rs --crate-type lib --emit=dep-info,link -C opt-level=3 --cfg 'feature="default"' --cfg 'feature="std"' -C metadata=3837ab229d65deb8 -C extra-filename=-3837ab229d65deb8 --out-dir /builddir/build/BUILD/tokio-io-0.1.6/target/release/deps -L dependency=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps --cap-lints allow -Copt-level=3 -Cdebuginfo=2 -Clink-arg=-Wl,-z,relro,-z,now`
   Compiling log v0.4.1
     Running `/usr/bin/rustc --crate-name log /usr/share/cargo/registry/log-0.4.1/src/lib.rs --crate-type lib --emit=dep-info,link -C opt-level=3 -C metadata=fa14a88080f9a687 -C extra-filename=-fa14a88080f9a687 --out-dir /builddir/build/BUILD/tokio-io-0.1.6/target/release/deps -L dependency=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps --extern cfg_if=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps/libcfg_if-b0daed5ecce94f78.rlib --cap-lints allow -Copt-level=3 -Cdebuginfo=2 -Clink-arg=-Wl,-z,relro,-z,now`
   Compiling iovec v0.1.2
     Running `/usr/bin/rustc --crate-name iovec /usr/share/cargo/registry/iovec-0.1.2/src/lib.rs --crate-type lib --emit=dep-info,link -C opt-level=3 -C metadata=579ae4e322a8e03a -C extra-filename=-579ae4e322a8e03a --out-dir /builddir/build/BUILD/tokio-io-0.1.6/target/release/deps -L dependency=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps --extern libc=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps/liblibc-3f2bf739f781a931.rlib --cap-lints allow -Copt-level=3 -Cdebuginfo=2 -Clink-arg=-Wl,-z,relro,-z,now`
   Compiling bytes v0.4.7
     Running `/usr/bin/rustc --crate-name bytes /usr/share/cargo/registry/bytes-0.4.7/src/lib.rs --crate-type lib --emit=dep-info,link -C opt-level=3 -C metadata=217cdba67d2b663d -C extra-filename=-217cdba67d2b663d --out-dir /builddir/build/BUILD/tokio-io-0.1.6/target/release/deps -L dependency=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps --extern byteorder=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps/libbyteorder-3837ab229d65deb8.rlib --extern iovec=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps/libiovec-579ae4e322a8e03a.rlib --cap-lints allow -Copt-level=3 -Cdebuginfo=2 -Clink-arg=-Wl,-z,relro,-z,now`
   Compiling tokio-io v0.1.6 (file:///builddir/build/BUILD/tokio-io-0.1.6)
     Running `/usr/bin/rustc --crate-name tokio_io src/lib.rs --crate-type lib --emit=dep-info,link -C opt-level=3 -C metadata=2e35cdf62a7ca3f5 -C extra-filename=-2e35cdf62a7ca3f5 --out-dir /builddir/build/BUILD/tokio-io-0.1.6/target/release/deps -L dependency=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps --extern futures=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps/libfutures-83d86e5cd520b9a1.rlib --extern log=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps/liblog-fa14a88080f9a687.rlib --extern bytes=/builddir/build/BUILD/tokio-io-0.1.6/target/release/deps/libbytes-217cdba67d2b663d.rlib -Copt-level=3 -Cdebuginfo=2 -Clink-arg=-Wl,-z,relro,-z,now`
error: use of deprecated item 'bytes::Buf::get_uint': use get_uint_be or get_uint_le
   --> src/length_delimited.rs:294:21
    |
294 |                 src.get_uint::<BigEndian>(field_len)
    |                     ^^^^^^^^
    |
note: lint level defined here
   --> src/lib.rs:9:54
    |
9   | #![deny(missing_docs, missing_debug_implementations, warnings)]
    |                                                      ^^^^^^^^
    = note: #[deny(deprecated)] implied by #[deny(warnings)]
error: use of deprecated item 'bytes::Buf::get_uint': use get_uint_be or get_uint_le
   --> src/length_delimited.rs:296:21
    |
296 |                 src.get_uint::<LittleEndian>(field_len)
    |                     ^^^^^^^^
error: use of deprecated item 'bytes::BufMut::put_uint': use put_uint_be or put_uint_le
   --> src/length_delimited.rs:482:18
    |
482 |             head.put_uint::<BigEndian>(n as u64, self.builder.length_field_len);
    |                  ^^^^^^^^
error: use of deprecated item 'bytes::BufMut::put_uint': use put_uint_be or put_uint_le
   --> src/length_delimited.rs:484:18
    |
484 |             head.put_uint::<LittleEndian>(n as u64, self.builder.length_field_len);
    |                  ^^^^^^^^
error: aborting due to 4 previous errors
error: Could not compile `tokio-io`.
```


Note You need to log in before you can comment on or make changes to this bug.