Bug 1573811 - GDM login does not work for existing users after upgrade to FC28 from FC27
Summary: GDM login does not work for existing users after upgrade to FC28 from FC27
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gdm
Version: 28
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2018-05-02 10:01 UTC by Tich
Modified: 2018-05-02 14:05 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2018-05-02 14:05:50 UTC
Type: Bug


Attachments (Terms of Use)

Description Tich 2018-05-02 10:01:01 UTC
Description of problem:

After upgrading from DC27 to FC28, my existing users fails to authenticate at the GDM login screen. The same users work in the text console. Any new users created, work both in the text console and in the GDM. The existing users can run startx properly and the GNOME environment appears, just I need to unlock the keyring

Version-Release number of selected component (if applicable):

gdm-3.28.1-1.fc28.x86_64


How reproducible:


Steps to Reproduce:
1.Install FC27 and create users
2.Upgrade to FC28
3.Try to login with existing users

Actual results:
Fails to authenticate


Expected results:
User properly authenticated


Additional info:

Comment 1 Tich 2018-05-02 10:34:48 UTC
Some of the messages in the journalctl output:

May 02 12:24:38 pinky unix_chkpwd[6046]: password check failed for user (tich)
May 02 12:24:38 pinky gdm-password][6042]: pam_unix(gdm-password:auth): authentication failure; logname= uid=0 euid=0 tty=/dev/tty1 ruser= rhost=  user=tich
May 02 12:24:38 pinky audit[6042]: USER_AUTH pid=6042 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 msg='op=PAM:authentication grantors=? acct="tich" exe="/usr/libexec/gdm-ses>
May 02 12:24:41 pinky audit[6042]: USER_LOGIN pid=6042 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:xdm_t:s0-s0:c0.c1023 msg='uid=3001 exe="/usr/libexec/gdm-session-worker" hostname=? addr=? term>
May 02 12:24:43 pinky gnome-shell[5803]: Object Gdm.UserVerifierProxy (0x55b56ef6f610), has been already deallocated - impossible to access to it. This might be caused by the fact that the object has been destr>
May 02 12:24:43 pinky org.gnome.Shell.desktop[5803]: == Stack trace for context 0x55b56d697060 ==
May 02 12:24:43 pinky org.gnome.Shell.desktop[5803]: #0 0x55b56d9ab1b0 i   resource:///org/gnome/shell/gdm/util.js:436 (0x7fb5bc084de0 @ 14)
May 02 12:24:49 pinky audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-localed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=?>
May 02 12:24:50 pinky audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=systemd-hostnamed comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr>
May 02 12:24:50 pinky audit[1]: SERVICE_STOP pid=1 uid=0 auid=4294967295 ses=4294967295 subj=system_u:system_r:init_t:s0 msg='unit=fprintd comm="systemd" exe="/usr/lib/systemd/systemd" hostname=? addr=? termina>
May 02 12:24:53 pinky unix_chkpwd[6059]: password check failed for user (tich)
May 02 12:24:53 pinky gdm-password][6049]: pam_unix(gdm-password:auth): authentication failure; logname= uid=0 euid=0 tty=/dev/tty1 ruser= rhost=  user=tich

Comment 2 Tich 2018-05-02 14:05:13 UTC
This does not seem like a bug in gdm. It seems that changing the keyboard language (to EN) to type the password makes it work properly. When I have my keyboard in Spanish, the password is the same and I am sure I am typing it okay, but it does not seem to work. Not sure if this is a bug or which the part failing here.


Note You need to log in before you can comment on or make changes to this bug.